Home page logo
/

basics logo Security Basics mailing list archives

RE: Setting up mail server(s) ?
From: "Rhett Grant" <rgrant () nextsequence com>
Date: Thu, 24 Apr 2008 16:41:48 -0400

 
Thanks for all the responses.

I went with qmail+clamav and spamassassin, it seems to be working fine
for the moment, i do however get some strange log activity sometimes:

clamdscan: corrupt or unknown clamd scanner error or memory/resourc
e/perms problem - exit status 512/2

I've been googlin a bit and havent found a "real" solution to the
problem.
Someone suggested running clamd as root, is that really a good idea?
Another suggested to remove clamd_scanner from the scanner_array in
qmail-scanner-queue.pl.

The box has 1GB RAM an, so i assume its not a memory problem (checked
ramusage while that error popped up in the logs)

resource/perms problem, how can i check which resources it needs
and/or which permissions are needed?

// Thanks in advance

I would suggest using John Simpsons patches to run Qmail.  His website is a
vast repository for Qmail related stuff including getting Clam Antivirus to
play nicely with qmail.  Your just having a permission problem which is not
to hard to solve.  Check out http://qmail.jms1.net/ (Don't use IE when
visiting it)

Also you can look at Qmailrocks at www.qmailrocks.org but it is out of date
software wise.  It will have some good instructions to help you understand
what you are doing.

And running Clamd as root is just asking for tons of trouble, do NOT do
that!!!!

Rhett Grant


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]