Home page logo
/

bugtraq logo Bugtraq mailing list archives

[CLA-2001:374] Conectiva Linux Security Announcement - icecast
From: secure () CONECTIVA COM BR
Date: Thu, 25 Jan 2001 13:58:56 -0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
CONECTIVA LINUX SECURITY ANNOUNCEMENT
- --------------------------------------------------------------------------

PACKAGE   : icecast
SUMMARY   : Remote root exploit
DATE      : 2001-01-25 13:58:00
ID        : CLA-2001:374
RELEVANT
RELEASES  : 4.1, 4.2, 5.0, 5.1, 6.0

- -------------------------------------------------------------------------

DESCRIPTION
 "icecast" is a server used to distribute audio streams to compatible
 clients such as winamp, mpg123, xmms and many others.
 The "Packet Knights" group has found a format string vulnerability on
 this program that could be used to remotely execute arbitrary code on
 the server with the privileges of the user running it, normally root.
 This can lead to remote root compromise.


SOLUTION
 It is recommended that all icecast users upgrade their servers.
 The new packages fix this problem and also provide some new
 features:
 - the icecast daemon now runs as the unprivileged user "icecast" and
 not root;
 - it is not possible to start the server if the default password has
 not been changed;
 - remote web administration has been turned off by default.


DIRECT DOWNLOAD LINKS TO THE UPDATED PACKAGES
ftp://atualizacoes.conectiva.com.br/4.1/SRPMS/icecast-1.3.7-4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/4.1/i386/icecast-1.3.7-4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/4.2/SRPMS/icecast-1.3.7-4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/4.2/i386/icecast-1.3.7-4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/5.0/SRPMS/icecast-1.3.7-4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/5.0/i386/icecast-1.3.7-4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/5.1/SRPMS/icecast-1.3.7-4cl.src.rpm
ftp://atualizacoes.conectiva.com.br/5.1/i386/icecast-1.3.7-4cl.i386.rpm
ftp://atualizacoes.conectiva.com.br/6.0/SRPMS/icecast-1.3.7-3cl.src.rpm
ftp://atualizacoes.conectiva.com.br/6.0/RPMS/icecast-1.3.7-3cl.i386.rpm


ADDITIONAL INSTRUCTIONS
 Users of Conectiva Linux version 6.0 or higher may use apt to perform
 upgrades:
 - add the following line to /etc/apt/sources.list if it is not there yet
   (you may also use linuxconf to do this):

 rpm [cncbr] ftp://atualizacoes.conectiva.com.br 6.0/conectiva updates

 - run:                 apt-get update
 - after that, execute: apt-get upgrade

 Detailed instructions reagarding the use of apt and upgrade examples
 can be found at http://distro.conectiva.com.br/atualizacoes/#apt?idioma=en


- -------------------------------------------------------------------------
All packages are signed with Conectiva's GPG key. The key and instructions
on how to import it can be found at
http://distro.conectiva.com.br/seguranca/chave/?idioma=en
Instructions on how to check the signatures of the RPM packages can be
found at http://distro.conectiva.com.br/seguranca/politica/?idioma=en

- -------------------------------------------------------------------------
All our advisories and generic update instructions can be viewed at
http://www.conectiva.com.br/suporte/atualizacoes

- -------------------------------------------------------------------------
subscribe: conectiva-updates-subscribe () papaleguas conectiva com br
unsubscribe: conectiva-updates-unsubscribe () papaleguas conectiva com br
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.4 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE6cE0/42jd0JmAcZARAnTXAJ45OkCe11YSpXE83MTrFnzQboTm+gCgvDE/
ePpvbDc0eKvYnpIDLjCecpk=
=jJzG
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [CLA-2001:374] Conectiva Linux Security Announcement - icecast secure (Jan 25)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]