Home page logo
/

bugtraq logo Bugtraq mailing list archives

[SECURITY] [DSA 161-1] New Mantis package fixes privilege escalation
From: joey () infodrom org (Martin Schulze)
Date: Wed, 4 Sep 2002 16:48:40 +0200 (CEST)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 161-1                     security () debian org
http://www.debian.org/security/                             Martin Schulze
September 4th, 2002                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : privilege escalation
Problem-Type   : remote
Debian-specific: no

A problem with user privileges has been discovered in the Mantis
package, a PHP based bug tracking system.  The Mantis system didn't
check whether a user is permitted to view a bug, but displays it right
away if the user entered a valid bug id.

Another bug in Mantis caused the 'View Bugs' page to list bugs from
both public and private projects when no projects are accessible to
the current user.

These problems have been fixed in version 0.17.1-2.5 for the current
stable distribution (woody) and in version 0.17.5-2 for the unstable
distribution (sid).  The old stable distribution (potato) is not
affected, since it doesn't contain the mantis package.

We recommend that you upgrade your mantis packages.

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.17.1-2.5.dsc
      Size/MD5 checksum:      572 00aad7574f22125e001d3b243bad9fdb
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.17.1-2.5.diff.gz
      Size/MD5 checksum:    15188 23e1e66e5285bcbb33ebf7d7a80ebd5e
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.17.1.orig.tar.gz
      Size/MD5 checksum:   220458 d8bac093eaf31ef5812e714db5c07f82

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.17.1-2.5_all.deb
      Size/MD5 checksum:   250066 e1b6b6240c18fcdd943a85407a494779


  These files will probably be moved into the stable distribution on
  its next revision.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce () lists debian org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE9dh1HW5ql+IAeqTIRAs+zAJ9Q0aBdG1lDqUlF0NTQPnUS8qcK2ACghImz
HP47/FcqYtvpui8SK2REeg8=
=vl8A
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [SECURITY] [DSA 161-1] New Mantis package fixes privilege escalation Martin Schulze (Sep 04)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]