Home page logo
/

bugtraq logo Bugtraq mailing list archives

[RHSA-2003:241-01] Updated ddskk packages fix temporary file vulnerability
From: bugzilla () redhat com
Date: Mon, 11 Aug 2003 03:30 -0400

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Updated ddskk packages fix temporary file vulnerability
Advisory ID:       RHSA-2003:241-01
Issue date:        2003-08-11
Updated on:        2003-08-11
Product:           Red Hat Linux
Keywords:          tmpfile
Cross references:  
Obsoletes:         
CVE Names:         CAN-2003-0539
- ---------------------------------------------------------------------

1. Topic:

Updated ddskk packages which fix a temporary file security issue are now
available.

2. Relevant releases/architectures:

Red Hat Linux 7.1 - noarch
Red Hat Linux 7.2 - noarch
Red Hat Linux 7.3 - noarch
Red Hat Linux 8.0 - noarch
Red Hat Linux 9 - noarch

3. Problem description:

Daredevil SKK is a simple Kana to Kanji conversion program, an input method 
of Japanese for Emacs and XEmacs.

ddskk does not take appropriate security precautions when creating
temporary files. This bug could potentially be exploited to overwrite
arbitrary files with the privileges of the user running Emacs and skk.  The
Common Vulnerabilities and Exposures project (cve.mitre.org) has allocated
the name CAN-2003-0539 to this issue.

All users of ddskk should upgrade to these erratum packages containing a
backported security patch that corrects this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which are
not installed but included in the list will not be updated.  Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network.  Many
people find this an easier way to apply updates.  To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

5. Bug IDs fixed (http://bugzilla.redhat.com/bugzilla for more info):

98924 - CAN-2003-0539 ddskk temporary file vulnerability

6. RPMs required:

Red Hat Linux 7.1:

SRPMS:
ftp://updates.redhat.com/7.1/en/os/SRPMS/ddskk-11.6.0-1.7.src.rpm

noarch:
ftp://updates.redhat.com/7.1/en/os/noarch/ddskk-11.6.0-1.7.noarch.rpm

Red Hat Linux 7.2:

SRPMS:
ftp://updates.redhat.com/7.2/en/os/SRPMS/ddskk-11.6.0-1.7.src.rpm

noarch:
ftp://updates.redhat.com/7.2/en/os/noarch/ddskk-11.6.0-1.7.noarch.rpm

Red Hat Linux 7.3:

SRPMS:
ftp://updates.redhat.com/7.3/en/os/SRPMS/ddskk-11.6.0-11.73.src.rpm

noarch:
ftp://updates.redhat.com/7.3/en/os/noarch/ddskk-11.6.0-11.73.noarch.rpm
ftp://updates.redhat.com/7.3/en/os/noarch/ddskk-xemacs-11.6.0-11.73.noarch.rpm

Red Hat Linux 8.0:

SRPMS:
ftp://updates.redhat.com/8.0/en/os/SRPMS/ddskk-11.6.0-11.80.src.rpm

noarch:
ftp://updates.redhat.com/8.0/en/os/noarch/ddskk-11.6.0-11.80.noarch.rpm
ftp://updates.redhat.com/8.0/en/os/noarch/ddskk-xemacs-11.6.0-11.80.noarch.rpm

Red Hat Linux 9:

SRPMS:
ftp://updates.redhat.com/9/en/os/SRPMS/ddskk-11.6.0-11.90.src.rpm

noarch:
ftp://updates.redhat.com/9/en/os/noarch/ddskk-11.6.0-11.90.noarch.rpm
ftp://updates.redhat.com/9/en/os/noarch/ddskk-xemacs-11.6.0-11.90.noarch.rpm



7. Verification:

MD5 sum                          Package Name
- --------------------------------------------------------------------------
ad2f068e78f849bfc86a80633116b2ce 7.1/en/os/SRPMS/ddskk-11.6.0-1.7.src.rpm
a50846679107d8ecf3f95d6858808d38 7.1/en/os/noarch/ddskk-11.6.0-1.7.noarch.rpm
ad2f068e78f849bfc86a80633116b2ce 7.2/en/os/SRPMS/ddskk-11.6.0-1.7.src.rpm
a50846679107d8ecf3f95d6858808d38 7.2/en/os/noarch/ddskk-11.6.0-1.7.noarch.rpm
499cd5de7e358901d7c1cc3e29077273 7.3/en/os/SRPMS/ddskk-11.6.0-11.73.src.rpm
59ca022c65a60000894debc826ff2e04 7.3/en/os/noarch/ddskk-11.6.0-11.73.noarch.rpm
ecc8acb7693f53de7b37c1d48283416f 7.3/en/os/noarch/ddskk-xemacs-11.6.0-11.73.noarch.rpm
82e9b3cde4970d94e02bd30cace9b87d 8.0/en/os/SRPMS/ddskk-11.6.0-11.80.src.rpm
e20c214d46128c94b074e52960539688 8.0/en/os/noarch/ddskk-11.6.0-11.80.noarch.rpm
403925f3e025e778138bb4b4b4278115 8.0/en/os/noarch/ddskk-xemacs-11.6.0-11.80.noarch.rpm
54674aa6a5312c8add642d4eea303015 9/en/os/SRPMS/ddskk-11.6.0-11.90.src.rpm
0a6f50765004b7a66711d9e5e8bef8d1 9/en/os/noarch/ddskk-11.6.0-11.90.noarch.rpm
81d5b6cd7930ba9766dc3e23a9a2dadd 9/en/os/noarch/ddskk-xemacs-11.6.0-11.90.noarch.rpm


These packages are GPG signed by Red Hat for security.  Our key is
available from http://www.redhat.com/security/keys.html

You can verify each package with the following command:
    
    rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the md5sum with the following command:
    
    md5sum <filename>


8. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0539

9. Contact:

The Red Hat security contact is <secalert () redhat com>.  More contact
details at http://www.redhat.com/solutions/security/news/contact.html

Copyright 2003 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE/N0YaXlSAg2UNWIIRAjflAJ0dvWpaZDF64oD65h5z08s4e/O4/QCgpLer
EXwawbMh86M43O3dSvgJdjY=
=x+ec
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [RHSA-2003:241-01] Updated ddskk packages fix temporary file vulnerability bugzilla (Aug 11)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]