Home page logo
/

bugtraq logo Bugtraq mailing list archives

GLSA: pam_smb (200309-01)
From: aliz () gentoo org (Daniel Ahlberg)
Date: Mon, 1 Sep 2003 14:47:01 +0200 (CEST)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - ---------------------------------------------------------------------
GENTOO LINUX SECURITY ANNOUNCEMENT 200309-01
- - - ---------------------------------------------------------------------

          PACKAGE : pam_smb
          SUMMARY : buffer overflow
             DATE : 2003-09-01 12:46 UTC
          EXPLOIT : remote
VERSIONS AFFECTED : <pam_smb-2.0.0_rc5
    FIXED VERSION : >=pam_smb-2.0.0_rc5
              CVE : CAN-2003-0686

- - - ---------------------------------------------------------------------

quote from Debian DSA-374-1:

"If a long password is supplied, this can cause a buffer overflow which 
could be exploited to execute arbitrary code with the privileges of the 
process which invokes PAM services."

SOLUTION

It is recommended that all Gentoo Linux users who are running
net-misc/pam_smb upgrade to pam_smb-2.0.0_rc5 as follows

emerge sync
emerge pam_smb
emerge clean

- - - ---------------------------------------------------------------------
aliz () gentoo org - GnuPG key is available at http://dev.gentoo.org/~aliz
- - - ---------------------------------------------------------------------
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/Uz/FfT7nyhUpoZMRAsRiAJ0R8MVvjcaEddXJ4pl4dIVPE8ORlACeO3uK
ew9VOE2h7NwVEhuJUCSFp/Y=
=wMpX
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault