Home page logo
/

bugtraq logo Bugtraq mailing list archives

MDKSA-2003:095 - Updated proftpd packages fix remote root vulnerability
From: Mandrake Linux Security Team <security () linux-mandrake com>
Date: 26 Sep 2003 22:50:01 -0000

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

________________________________________________________________________

                Mandrake Linux Security Update Advisory
________________________________________________________________________

Package name:           proftpd
Advisory ID:            MDKSA-2003:095
Date:                   September 26th, 2003

Affected versions:      9.1, 9.2
________________________________________________________________________

Problem Description:

 A vulnerability was discovered by X-Force Research at ISS in ProFTPD's
 handling of ASCII translation.  An attacker, by downloading a carefully
 crafted file, can remotely exploit this bug to create a root shell.
 
 The ProFTPD team encourages all users to upgrade to version 1.2.7 or
 higher.  The problematic code first appeared in ProFTPD 1.2.7rc1, and
 the provided packages are all patched by the ProFTPD team to protect
 against this vulnerability.
________________________________________________________________________

References:
  
  http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2003-0831
  http://xforce.iss.net/xforce/alerts/id/154
________________________________________________________________________

Updated Packages:
  
 Mandrake Linux 9.1:
 b00bae0743aec3e1decccaf73a356b84  9.1/RPMS/proftpd-1.2.8-1.1.91mdk.i586.rpm
 6a85248750d88db30b658ee51fdebcf1  9.1/RPMS/proftpd-anonymous-1.2.8-1.1.91mdk.i586.rpm
 c04242b94a7451164e42e96bbf648e5d  9.1/SRPMS/proftpd-1.2.8-1.1.91mdk.src.rpm

 Mandrake Linux 9.1/PPC:
 a053b5f2fa6e57ee884465385937041f  ppc/9.1/RPMS/proftpd-1.2.8-1.1.91mdk.ppc.rpm
 55d22b28017dfaab6f2da238d5d8311c  ppc/9.1/RPMS/proftpd-anonymous-1.2.8-1.1.91mdk.ppc.rpm
 c04242b94a7451164e42e96bbf648e5d  ppc/9.1/SRPMS/proftpd-1.2.8-1.1.91mdk.src.rpm

 Mandrake Linux 9.2:
 1d9b21bcb2a18fa43158c0c0aa25d13d  9.2/RPMS/proftpd-1.2.8-5.1.92mdk.i586.rpm
 80c5b73c6e33444e2dd91659c2b897bd  9.2/RPMS/proftpd-anonymous-1.2.8-5.1.92mdk.i586.rpm
 ea89351b37a5572fac3f45b27a80b0f3  9.2/SRPMS/proftpd-1.2.8-5.1.92mdk.src.rpm
________________________________________________________________________

Bug IDs fixed (see https://qa.mandrakesoft.com for more information):
________________________________________________________________________

To upgrade automatically, use MandrakeUpdate or urpmi.  The verification
of md5 checksums and GPG signatures is performed automatically for you.

A list of FTP mirrors can be obtained from:

  http://www.mandrakesecure.net/en/ftp.php

All packages are signed by MandrakeSoft for security.  You can obtain
the GPG public key of the Mandrake Linux Security Team by executing:

  gpg --recv-keys --keyserver www.mandrakesecure.net 0x22458A98

Please be aware that sometimes it takes the mirrors a few hours to
update.

You can view other update advisories for Mandrake Linux at:

  http://www.mandrakesecure.net/en/advisories/

MandrakeSoft has several security-related mailing list services that
anyone can subscribe to.  Information on these lists can be obtained by
visiting:

  http://www.mandrakesecure.net/en/mlist.php

If you want to report vulnerabilities, please contact

  security_linux-mandrake.com

Type Bits/KeyID     Date       User ID
pub  1024D/22458A98 2000-07-10 Linux Mandrake Security Team
  <security linux-mandrake.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (GNU/Linux)

iD8DBQE/dMKZmqjQ0CJFipgRAr9VAJ9VtLskLbYmZ6e2fPKwz0BFjkGsWACg1VPw
PumsSXrNduTY+1HaaqplD8g=
=5eUR
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • MDKSA-2003:095 - Updated proftpd packages fix remote root vulnerability Mandrake Linux Security Team (Sep 26)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]