Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200408-07 ] Horde-IMP: Input validation vulnerability for Internet Explorer users
From: Kurt Lieber <klieber () gentoo org>
Date: Tue, 10 Aug 2004 13:04:31 +0000

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200408-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Horde-IMP: Input validation vulnerability for Internet
            Explorer users
      Date: August 10, 2004
      Bugs: #59336
        ID: 200408-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An input validation vulnerability has been discovered in Horde-IMP.
This only affects users of Internet Explorer.

Background
==========

Horde-IMP is the Internet Messaging Program. It is written in PHP and
provides webmail access to IMAP and POP3 accounts.

Affected packages
=================

    -------------------------------------------------------------------
     Package            /   Vulnerable   /                  Unaffected
    -------------------------------------------------------------------
  1  net-www/horde-imp       <= 3.2.4                         >= 3.2.5

Description
===========

Horde-IMP fails to properly sanitize email messages that contain
malicious HTML or script code so that it is not safe for users of
Internet Explorer when using the inline MIME viewer for HTML messages.

Impact
======

By enticing a user to read a specially crafted e-mail, an attacker can
execute arbitrary scripts running in the context of the victim's
browser. This could lead to a compromise of the user's webmail account,
cookie theft, etc.

Workaround
==========

Do not use Internet Explorer to access Horde-IMP.

Resolution
==========

All Horde-IMP users should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=horde-imp-3.2.5"
    # emerge ">=horde-imp-3.2.5"

References
==========

  [ 1 ] Horde-IMP Changelog
        http://cvs.horde.org/diff.php/imp/docs/CHANGES?r1=1.389.2.106&r2=1.389.2.109&ty=h
  [ 2 ] Secunia Advisory SA12202
        http://secunia.com/advisories/12202/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200408-07.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200408-07 ] Horde-IMP: Input validation vulnerability for Internet Explorer users Kurt Lieber (Aug 10)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault