Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200408-10 ] gv: Exploitable Buffer Overflow
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Thu, 12 Aug 2004 13:33:07 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200408-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: gv: Exploitable Buffer Overflow
      Date: August 12, 2004
      Bugs: #59385
        ID: 200408-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

gv contains an exploitable buffer overflow that allows an attacker to
execute arbitrary code.

Background
==========

gv is a PostScript and PDF viewer for X which provides a user interface
for the ghostscript interpreter.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /   Vulnerable   /                        Unaffected
    -------------------------------------------------------------------
  1  app-text/gv      <= 3.5.8-r3                          >= 3.5.8-r4

Description
===========

gv contains a buffer overflow vulnerability where an unsafe sscanf()
call is used to interpret PDF and PostScript files.

Impact
======

By enticing a user to view a malformed PDF or PostScript file an
attacker could execute arbitrary code with the permissions of the user
running gv.

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of gv.

Resolution
==========

All gv users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=app-text/gv-3.5.8-r4"
    # emerge ">=app-text/gv-3.5.8-r4"

References
==========

  [ 1 ] CAN-2002-0838
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2002-0838

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    http://security.gentoo.org/glsa/glsa-200408-10.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBG1VzzKC5hMHO6rkRAnvTAJ4qHGounyrnZD4LdkcYK+edrKDlkgCeJgjz
VixGMT9TOgt24mDQyFJa018=
=FofW
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault