Home page logo
/

bugtraq logo Bugtraq mailing list archives

RE: Driver for display goes to a infinite loop by viewing a html!
From: Christopher Wagner <chrisw () pacaids com>
Date: Mon, 16 Aug 2004 16:09:28 -0700

In the interest of yet more completeness, I tested this on a few different
machines here at my office, here are the results:

Test image was 10000000px by 10000000px - ~11kb in size

It appears as all black in Mozilla of any version/platform/arch I tried.

Mozilla Firefox 0.9.3 operates slowly (not surprising considering size of
image)

Internet Explorer 6 SP1 hangs for a bit, displays nothing other than just
the text on the HTML page, then crashes the system as the original report
states.

I tried this with an Intel 82845G/GL/GE/PE/GV (That's what the driver is
labelled at anyrate).  It's integrated into my Dell Dimension 2400's
motherboard.  Running WinXP Pro, updated to everything short of SP2.

The other OS, browser, and system combinations I tried merely responded the
same; very slow response.  It seems the crash problem can only be recreated
in IE, no surprises there.

My guess, from my limited knowledge of the way video cards and their drivers
function, it's probably a bug in how IE is interacting with the video
driver.  Although, this is merely a guess, and I certainly can't truly point
a finger at M$ or Intel with any certainty.  Maybe someone with some
experience of such things can point a finger better than I. :)

I hope this helps track down the problem.

- Christopher Wagner
<chrisw () pacaids com>

-----Original Message-----
From: Frank Nospam [mailto:fuy1 () umbc edu]
Sent: Thursday, August 12, 2004 1:33 PM
To: bugtraq () securityfocus com
Subject: Re: Driver for display goes to a infinite loop by viewing a
html!


For the sake of completeness: Mac OS X 10.3.5 doesn't crash or
  consume excess CPU cycles at your test page.

The only notable quirk was a failure to scale the test image:
  Safari 1.2.3 (KHTML) displayed a blank space 999999 pixels tall
  and Mozilla 1.8a displayed a 999999x999999 black box.


On 11 Aug 2004 12:11:06 -0000, Bipin Gautam <visitbipin () hotmail com> 
wrote:
http://www.geocities.com/visitbipin/crazy.html
Try scrolling the picture for few seconds...[ don't kill the process] 
I have tested it on several machines with intel vga. it reboots Winxp 
with a fetal error because The driver for the display device got 
stuck in an infinite loop.


--
  ? http://geocities.com/francis_uy=


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault