Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200408-26 ] zlib: Denial of service vulnerability
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Fri, 27 Aug 2004 20:48:13 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200408-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: zlib: Denial of service vulnerability
      Date: August 27, 2004
      Bugs: #61749
        ID: 200408-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The zlib library contains a Denial of Service vulnerability.

Background
==========

zlib is a general-purpose data-compression library.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /   Vulnerable   /                      Unaffected
    -------------------------------------------------------------------
  1  sys-libs/zlib      <= 1.2.1-r2                        >= 1.2.1-r3

Description
===========

zlib contains a bug in the handling of errors in the "inflate()" and
"inflateBack()" functions.

Impact
======

An attacker could exploit this vulnerability to launch a Denial of
Service attack on any application using the zlib library.

Workaround
==========

There is no known workaround at this time. All users are encouraged to
upgrade to the latest available version of zlib.

Resolution
==========

All zlib users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=sys-libs/zlib-1.2.1-r3"
    # emerge ">=sys-libs/zlib-1.2.1-r3"

You should also run revdep-rebuild to rebuild any packages that depend
on older versions of zlib :

    # revdep-rebuild

References
==========

  [ 1 ] OpenPKG-SA-2004.038-zlib
        http://www.openpkg.org/security/OpenPKG-SA-2004.038-zlib.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200408-26.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBL4HwzKC5hMHO6rkRAh2AAJ9FErl2R7QrRcOuPCSfUojOsMIhKwCePwDq
Fi2c3A5pOl+YXWbZV0/om70=
=i0HL
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [ GLSA 200408-26 ] zlib: Denial of service vulnerability Sune Kloppenborg Jeppesen (Aug 27)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault