Home page logo
/

bugtraq logo Bugtraq mailing list archives

Re: Patch available for multiple critical flaws in Oracle
From: Marc Bejarano <bugtraq () beej org>
Date: Sat, 18 Dec 2004 13:26:15 -0400

At 18:08 8/31/2004, NGSSoftware Insight Security Research wrote:
Researchers at NGSSoftware have discovered multiple critical vulnerabilities in Oracle Database Server and Oracle Application Server. Versions affected include

Oracle Database 10g Release 1 Version 10.1.0.2
Oracle9i Database Server Release 2, versions 9.2.0.4 and 9.2.0.5
Oracle9i Database Server Release 1, versions 9.0.1.4, 9.0.1.5 and 9.0.4
Oracle8i Database Server Release 3, version 8.1.7.4
Oracle Application Server 10g (9.0.4), versions 9.0.4.0 and 9.0.4.1
Oracle9i Application Server Release 2, versions 9.0.2.3 and 9.0.3.1
Oracle9i Application Server Release 1, version 1.0.2.2

The vulnerabilities range from buffer overflow issues, PL/SQL Injection, trigger abuse, character set conversion bugs and denial of service. On the 31st of August 2004 Oracle released a set of patches to address all of these issues (and for other flaws found by other researchers.) This patch set can be downloaded from the Metalink website - http://metalink.oracle.com/.

NGSSoftware are going to withhold details about these flaws for three months. Full details will be published on the 31st of November 2004. This three month window will allow Oracle database administrators the time needed to test and apply the patch set before the details are released to the general public. This reflects NGSSoftware's new approach to responsible disclosure.

ok.  it's been three months.  show us the goods, please :)

marc

  By Date           By Thread  

Current thread:
  • Re: Patch available for multiple critical flaws in Oracle Marc Bejarano (Dec 20)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault