Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200405-21 ] Midnight Commander: Multiple vulnerabilities
From: Kurt Lieber <klieber () gentoo org>
Date: Wed, 26 May 2004 12:31:54 -0400

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-21
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Midnight Commander: Multiple vulnerabilities
      Date: May 26, 2004
      Bugs: #49990
        ID: 200405-21

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple security issues have been discovered in Midnight Commander
including several buffer overflows and string format vulnerabilities.

Background
==========

Midnight Commander is a visual console file manager.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /   Vulnerable   /                        Unaffected
    -------------------------------------------------------------------
  1  app-misc/mc      <= 4.6.0-r6                          >= 4.6.0-r7

Description
===========

Numerous security issues have been discovered in Midnight Commander,
including several buffer overflow vulnerabilities, multiple
vulnerabilities in the handling of temporary file and directory
creation, and multiple format string vulnerabilities.

Impact
======

The buffer overflows and format string vulnerabilites may allow
attackers to cause a denial of service or execute arbitrary code with
permissions of the user running MC. The insecure creation of temporary
files and directories could lead to a privilege escalation, including
root privileges, for a local attacker.

Workaround
==========

There is no known workaround at this time. All users are advised to
upgrade to version 4.6.0-r7 or higher of Midnight Commander.

Resolution
==========

All Midnight Commander users should upgrade to the latest stable
version:

    # emerge sync

    # emerge -pv ">=app-misc/mc-4.6.0-r7
    # emerge ">=app-misc/mc-4.6.0-r7"

References
==========

  [ 1 ] CAN-2004-0226
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0226
  [ 2 ] CAN-2004-0231
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0231
  [ 3 ] CAN-2004-0232
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0232

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     http://security.gentoo.org/glsa/glsa-200405-21.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200405-21 ] Midnight Commander: Multiple vulnerabilities Kurt Lieber (May 26)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]