Home page logo
/

bugtraq logo Bugtraq mailing list archives

[FLSA-2005:168326] Updated util-linux and mount packages fix security issue
From: Marc Deslauriers <marcdeslauriers () videotron ca>
Date: Sun, 18 Dec 2005 00:17:49 -0500

---------------------------------------------------------------------
               Fedora Legacy Update Advisory

Synopsis:          Updated util-linux and mount packages fix security
                   issue
Advisory ID:       FLSA:168326
Issue date:        2005-12-18
Product:           Red Hat Linux, Fedora Core
Keywords:          Bugfix
CVE Names:         CVE-2005-2876
---------------------------------------------------------------------


---------------------------------------------------------------------
1. Topic:

Updated util-linux and mount packages that fix a security issue are
now available.

The util-linux package contains a large variety of low-level system
utilities that are necessary for a Linux system to function.

The mount package contains the mount, umount, swapon and swapoff
programs.

2. Relevant releases/architectures:

Red Hat Linux 7.3 - i386
Red Hat Linux 9 - i386
Fedora Core 1 - i386
Fedora Core 2 - i386

3. Problem description:

A bug was found in the way the umount command is executed by normal
users. It may be possible for a user to gain elevated privileges if the
user is able to execute the "umount -r" command on a mounted file
system. The file system will be re-mounted only with the "readonly" flag
set, clearing flags such as "nosuid" and "noexec". The Common
Vulnerabilities and Exposures project (cve.mitre.org) has assigned the
name CVE-2005-2876 to this issue.

All users of util-linux and mount should upgrade to these updated
packages, which contain a backported patch to correct this issue.

4. Solution:

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade.  Only those
RPMs which are currently installed will be updated.  Those RPMs which
are not installed but included in the list will not be updated.  Note
that you can also use wildcards (*.rpm) if your current directory *only*
contains the desired RPMs.

Please note that this update is also available via yum and apt.  Many
people find this an easier way to apply updates.  To use yum issue:

yum update

or to use apt:

apt-get update; apt-get upgrade

This will start an interactive process that will result in the
appropriate RPMs being upgraded on your system.  This assumes that you
have yum or apt-get configured for obtaining Fedora Legacy content.
Please visit http://www.fedoralegacy.org/docs for directions on how to
configure yum and apt-get.

5. Bug IDs fixed:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168326

6. RPMs required:

Red Hat Linux 7.3:
SRPM:
http://download.fedoralegacy.org/redhat/7.3/updates/SRPMS/util-linux-2.11n-12.7.3.2.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/7.3/updates/i386/mount-2.11n-12.7.3.2.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/7.3/updates/i386/util-linux-2.11n-12.7.3.2.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/7.3/updates/i386/losetup-2.11n-12.7.3.2.legacy.i386.rpm

Red Hat Linux 9:

SRPM:
http://download.fedoralegacy.org/redhat/9/updates/SRPMS/util-linux-2.11y-9.2.legacy.src.rpm

i386:
http://download.fedoralegacy.org/redhat/9/updates/i386/mount-2.11y-9.2.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/9/updates/i386/util-linux-2.11y-9.2.legacy.i386.rpm
http://download.fedoralegacy.org/redhat/9/updates/i386/losetup-2.11y-9.2.legacy.i386.rpm

Fedora Core 1:

SRPM:
http://download.fedoralegacy.org/fedora/1/updates/SRPMS/util-linux-2.11y-29.2.legacy.src.rpm

i386:
http://download.fedoralegacy.org/fedora/1/updates/i386/mount-2.11y-29.2.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/util-linux-2.11y-29.2.legacy.i386.rpm
http://download.fedoralegacy.org/fedora/1/updates/i386/losetup-2.11y-29.2.legacy.i386.rpm

Fedora Core 2:

SRPM:
http://download.fedoralegacy.org/fedora/2/updates/SRPMS/util-linux-2.12-19.1.legacy.src.rpm

i386:
http://download.fedoralegacy.org/fedora/2/updates/i386/util-linux-2.12-19.1.legacy.i386.rpm


7. Verification:

SHA1 sum                                 Package Name
---------------------------------------------------------------------

437139c00fbc4109ea3cd66b88a778a023d07298
redhat/7.3/updates/i386/mount-2.11n-12.7.3.2.legacy.i386.rpm
e39b80b435a545f87878cb2d4f6e89d89ec2c88f
redhat/7.3/updates/i386/util-linux-2.11n-12.7.3.2.legacy.i386.rpm
0c671214cb28d21b71917d04e4cdce3240515b45
redhat/7.3/updates/i386/losetup-2.11n-12.7.3.2.legacy.i386.rpm
a35553671d54999b0929f42a1283252b1cab1d18
redhat/7.3/updates/SRPMS/util-linux-2.11n-12.7.3.2.legacy.src.rpm
cbe71d4ed7c39c0ed186a548c194c44e3328595b
redhat/9/updates/i386/mount-2.11y-9.2.legacy.i386.rpm
926ae6d1c9f6d5309ab24c712cbe2a3ec97bba1c
redhat/9/updates/i386/util-linux-2.11y-9.2.legacy.i386.rpm
969d19231dc24415f7d761539b59ba772c716a36
redhat/9/updates/i386/losetup-2.11y-9.2.legacy.i386.rpm
9ac87483879c1df0ed9c100081e19b7614af8f79
redhat/9/updates/SRPMS/util-linux-2.11y-9.2.legacy.src.rpm
881c066cf8ec3aa25450a7e8db2f43e55faaef40
fedora/1/updates/i386/mount-2.11y-29.2.legacy.i386.rpm
f1b2f60ee7b5fb3149ab3b36133c930c6eecb788
fedora/1/updates/i386/util-linux-2.11y-29.2.legacy.i386.rpm
501380711d59e946f1dab5a40b0906525393d766
fedora/1/updates/i386/losetup-2.11y-29.2.legacy.i386.rpm
65519afd06a882abad31b847ad7053936dfd0ef4
fedora/1/updates/SRPMS/util-linux-2.11y-29.2.legacy.src.rpm
72c70f92397f84a3f021c6cef964fa0fb9b8cc57
fedora/2/updates/i386/util-linux-2.12-19.1.legacy.i386.rpm
2c93eefe88d57118fc2ddfee7fd5949e3d58c38f
fedora/2/updates/SRPMS/util-linux-2.12-19.1.legacy.src.rpm

These packages are GPG signed by Fedora Legacy for security.  Our key is
available from http://www.fedoralegacy.org/about/security.php

You can verify each package with the following command:

    rpm --checksig -v <filename>

If you only wish to verify that each package has not been corrupted or
tampered with, examine only the sha1sum with the following command:

    sha1sum <filename>

8. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2876

9. Contact:

The Fedora Legacy security contact is <secnotice () fedoralegacy org>. More
project details at http://www.fedoralegacy.org

---------------------------------------------------------------------

Attachment: signature.asc
Description: OpenPGP digital signature


  By Date           By Thread  

Current thread:
  • [FLSA-2005:168326] Updated util-linux and mount packages fix security issue Marc Deslauriers (Dec 19)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault