mailing list archives
[KDE Security Advisory] Multiple libgadu vulnerabilities
From: Dirk Mueller <mueller () kde org>
Date: Thu, 21 Jul 2005 02:16:44 +0200
KDE Security Advisory: libgadu vulnerabilities
Original Release Date: 2005-07-21
1. Systems affected:
All versions of Kopete as included in
KDE 3.3.x up to including 3.4.1. KDE 3.2.x and older
are not affected.
Kopete contains a copy of libgadu that is used if
no compatible version is installed in the system. Several
input validation errors have been reported in libgadu
that can lead to integer overflows and remote DoS or
arbitrary code execution.
If the Gadu-Gadu protocol handler in Kopete is used,
remote users can DoS the Kopete client or possibly even
execute arbitrary code.
Source code patches have been made available that update
the included copy of libgadu to 1.6rc3 which fix these
vulnerabilities. Contact your OS vendor / binary package provider
for information about how to obtain updated binary packages.
A patch for KDE 3.4.1 is available from
A patch for KDE 3.3.2 is available from
- [KDE Security Advisory] Multiple libgadu vulnerabilities Dirk Mueller (Jul 21)