Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200506-19 ] SquirrelMail: Several XSS vulnerabilities
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Tue, 21 Jun 2005 22:22:38 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200506-19
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: SquirrelMail: Several XSS vulnerabilities
      Date: June 21, 2005
      Bugs: #95937
        ID: 200506-19

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Squirrelmail is vulnerable to several cross-site scripting
vulnerabilities which could lead to a compromise of webmail accounts.

Background
==========

SquirrelMail is a webmail package written in PHP. It supports IMAP and
SMTP protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  mail-client/squirrelmail       < 1.4.4                   >= 1.4.4
                                                               < 1.4.0

Description
===========

SquirrelMail is vulnerable to several cross-site scripting issues, most
reported by Martijn Brinkers.

Impact
======

By enticing a user to read a specially-crafted e-mail or using a
manipulated URL, an attacker can execute arbitrary scripts running in
the context of the victim's browser. This could lead to a compromise of
the user's webmail account, cookie theft, etc.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All SquirrelMail users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.4"

Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

References
==========

  [ 1 ] SquirrelMail Advisory
        http://www.squirrelmail.org/security/issue/2005-06-15
  [ 2 ] CAN-2005-1769
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1769

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200506-19.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200506-19 ] SquirrelMail: Several XSS vulnerabilities Sune Kloppenborg Jeppesen (Jun 22)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault