Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200505-01 ] Horde Framework: Multiple XSS vulnerabilities
From: Luke Macken <lewk () gentoo org>
Date: Sun, 1 May 2005 12:10:12 -0400

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200505-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: Horde Framework: Multiple XSS vulnerabilities
      Date: May 01, 2005
      Bugs: #90365
        ID: 200505-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Various modules of the Horde Framework are vulnerable to multiple
cross-site scripting (XSS) vulnerabilities.

Background
==========

The Horde Framework is a PHP based framework for building web
applications. It provides many modules including calendar, address
book, CVS viewer and Internet Messaging Program.

Affected packages
=================

    -------------------------------------------------------------------
     Package                   /  Vulnerable  /             Unaffected
    -------------------------------------------------------------------
  1  www-apps/horde-vacation        < 2.2.2                   >= 2.2.2
  2  www-apps/horde-turba           < 1.2.5                   >= 1.2.5
  3  www-apps/horde-passwd          < 2.2.2                   >= 2.2.2
  4  www-apps/horde-nag             < 1.1.3                   >= 1.1.3
  5  www-apps/horde-mnemo           < 1.1.4                   >= 1.1.4
  6  www-apps/horde-kronolith       < 1.1.4                   >= 1.1.4
  7  www-apps/horde-imp             < 3.2.8                   >= 3.2.8
  8  www-apps/horde-accounts        < 2.1.2                   >= 2.1.2
  9  www-apps/horde-forwards        < 2.2.2                   >= 2.2.2
 10  www-apps/horde-chora           < 1.2.3                   >= 1.2.3
 11  www-apps/horde                 < 2.2.8                   >= 2.2.8
    -------------------------------------------------------------------
     11 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

Cross-site scripting vulnerabilities have been discovered in various
modules of the Horde Framework.

Impact
======

These vulnerabilities could be exploited by an attacker to execute
arbitrary HTML and script code in context of the victim's browser.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Horde users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-2.2.8"

All Horde Vacation users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-vacation-2.2.2"

All Horde Turba users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-turba-1.2.5"

All Horde Passwd users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-passwd-2.2.2"

All Horde Nag users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-nag-1.1.3"

All Horde Mnemo users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-mnemo-1.1.4"

All Horde Kronolith users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
    # ">=www-apps/horde-kronolith-1.1.4"

All Horde IMP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-imp-3.2.8"

All Horde Accounts users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-accounts-2.1.2"

All Horde Forwards users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-forwards-2.2.2"

All Horde Chora users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-apps/horde-chora-1.2.3"

References
==========

  [ 1 ] Horde Announcement
        http://marc.theaimsgroup.com/?l=horde-announce&r=1&b=200504&w=2

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200505-01.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200505-01 ] Horde Framework: Multiple XSS vulnerabilities Luke Macken (May 02)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault