Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200510-03 ] Uim: Privilege escalation vulnerability
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Tue, 4 Oct 2005 20:04:28 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200510-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Uim: Privilege escalation vulnerability
      Date: October 04, 2005
      Bugs: #107748
        ID: 200510-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Under certain conditions, applications linked against Uim suffer from a
privilege escalation vulnerability.

Background
==========

Uim is a multilingual input method library which provides secure and
useful input method for all languages.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  app-i18n/uim      < 0.4.9.1                            >= 0.4.9.1

Description
===========

Masanari Yamamoto discovered that Uim uses environment variables
incorrectly. This bug causes a privilege escalation if setuid/setgid
applications are linked to libuim. This bug only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE="immqt" or USE="immqt-bc").

Impact
======

A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Uim users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.9.1"

References
==========

  [ 1 ] Original advisory
        http://lists.freedesktop.org/pipermail/uim/2005-September/001346.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200510-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200510-03 ] Uim: Privilege escalation vulnerability Sune Kloppenborg Jeppesen (Oct 04)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault