Home page logo
/

bugtraq logo Bugtraq mailing list archives

TSLSA-2005-0047 - multi
From: Trustix Security Advisor <tsl () trustix org>
Date: Fri, 9 Sep 2005 12:34:01 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Trustix Secure Linux Security Advisory #2005-0047

Package names:     apache, openssh, squid   
Summary:           Multiple vulnerabilities
Date:              2005-09-09
Affected versions: Trustix Secure Linux 2.2
                   Trustix Secure Linux 3.0
                   Trustix Operating System - Enterprise Server 2

- --------------------------------------------------------------------------
Package description:
  apache 
  Apache is a full featured web server that is freely available, and also
  happens to be the most widely used.

  openssh
  Ssh (Secure Shell) a program for logging into a remote machine and for
  executing commands in a remote machine.  It is intended to replace
  rlogin and rsh, and provide secure encrypted communications between
  two untrusted hosts over an insecure network.  X11 connections and
  arbitrary TCP/IP ports can also be forwarded over the secure channel.
  
  squid
  Squid is a high-performance proxy caching server for Web clients,
  supporting FTP, gopher, and HTTP data objects. Unlike traditional
  caching software, Squid handles all requests in a single, non-blocking,
  I/O-driven process. Squid keeps meta data and especially hot objects
  cached in RAM, caches DNS lookups, supports non-blocking DNS lookups,
  and implements negative caching of failed requests. 

Problem description:
  apache < TSL 3.0 > < TSL 2.2 > < TSEL 2 >
  - SECURITY Fix: ssl_engine_kernel.c in mod_ssl before 2.8.24, when using
    "SSLVerifyClient optional" in the global virtual host configuration,
    does not properly enforce "SSLVerifyClient require" in a per-location
    context, which allows remote attackers to bypass intended access 
    restrictions.
  - The byte-range filter in Apache 2.0 allows remote attackers to cause a 
    denial of service (memory consumption) via an HTTP header with a large
    Range field.

    The Common Vulnerabilities and Exposures project has assigned the
    name CAN-2005-2700 and CAN-2005-2728 to this issue.

  openssh < TSL 3.0 > < TSL 2.2 > < TSEL 2 >
  - New Upstream
  - SECURITY Fix: An error in handling dynamic port forwardings when no
    listen address is specified, can cause "GatewayPorts" to be incorrectly
    activated.

  - An error in handling GSSAPI credential delegation can allow a user, who
    did not login using GSSAPI authentication, to be delegated with GSSAPI
    credentials.
    
    The Common Vulnerabilities and Exposures project has assigned the
    name CAN-2005-2798 to this issue.

  squid < TSL 3.0 > < TSL 2.2 > < TSEL 2 >
  - SECURITY Fix: Fixed DOS Vulnerability, Alex Masterov has reported a 
    vulnerability in Squid, which potentially can be exploited by malicious
    people to cause a DoS (Denial of Service). The vulnerability is caused
    due to an unspecified error in the "sslConnectTimeout()" function after
    handling malformed requests.
  - Fixed Squid crashes with the assertion failure in certain conditions
    involving aborted requests.

Action:
  We recommend that all systems with this package installed be upgraded.
  Please note that if you do not need the functionality provided by this
  package, you may want to remove it from your system.


Location:
  All Trustix Secure Linux updates are available from
  <URI:http://http.trustix.org/pub/trustix/updates/>
  <URI:ftp://ftp.trustix.org/pub/trustix/updates/>


About Trustix Secure Linux:
  Trustix Secure Linux is a small Linux distribution for servers. With focus
  on security and stability, the system is painlessly kept safe and up to
  date from day one using swup, the automated software updater.


Automatic updates:
  Users of the SWUP tool can enjoy having updates automatically
  installed using 'swup --upgrade'.


Questions?
  Check out our mailing lists:
  <URI:http://www.trustix.org/support/>


Verification:
  This advisory along with all Trustix packages are signed with the
  TSL sign key.
  This key is available from:
  <URI:http://www.trustix.org/TSL-SIGN-KEY>

  The advisory itself is available from the errata pages at
  <URI:http://www.trustix.org/errata/trustix-2.2/> and
  <URI:http://www.trustix.org/errata/trustix-3.0/>
  or directly at
  <URI:http://www.trustix.org/errata/2005/0047/>


MD5sums of the packages:
- --------------------------------------------------------------------------
3df22878f67bad946897344b3733cd39  3.0/rpms/apache-2.0.54-14tr.i586.rpm
18b39fa927f776f34cbce64411e1d94e  3.0/rpms/apache-dbm-2.0.54-14tr.i586.rpm
9af67af95df91f4d9012f317cbf07299  3.0/rpms/apache-devel-2.0.54-14tr.i586.rpm
5b8737e520cef12efecaf965ec2f718e  3.0/rpms/apache-html-2.0.54-14tr.i586.rpm
003cddf5179e10784dc27297f4868b5f  3.0/rpms/apache-manual-2.0.54-14tr.i586.rpm
a2e6a7f9791e7785475b9df5fb01cb0b  3.0/rpms/apache-suexec-2.0.54-14tr.i586.rpm
44220702fc00a30241d37961c0715234  3.0/rpms/openssh-4.2p1-1tr.i586.rpm
72620dff92855350cd1af66464843e39  3.0/rpms/openssh-clients-4.2p1-1tr.i586.rpm
75bfd330db73e9d26151ffd33953bb57  3.0/rpms/openssh-server-4.2p1-1tr.i586.rpm
a1219eb8320809024dd0a740213f24ca  3.0/rpms/openssh-server-config-4.2p1-1tr.i586.rpm
5806dc198b52d7354eee86537848b521  3.0/rpms/squid-2.5.STABLE10-5tr.i586.rpm

07781d51b3258b34ef45db67ac20b020  2.2/rpms/apache-2.0.54-8tr.i586.rpm
cadeb60f7a52640024eef2b1bc1560dd  2.2/rpms/apache-dbm-2.0.54-8tr.i586.rpm
b25261c87cd62d86a5fca8277be486f3  2.2/rpms/apache-devel-2.0.54-8tr.i586.rpm
6c7f8d433abdd279969a476576adf578  2.2/rpms/apache-html-2.0.54-8tr.i586.rpm
5e453ada97b5f5badd584c1deb8130e6  2.2/rpms/apache-manual-2.0.54-8tr.i586.rpm
3b980515b3a00f417195d2e513bf7e51  2.2/rpms/apache-suexec-2.0.54-8tr.i586.rpm
29922c6314c3b53abaf60f085f5d4f37  2.2/rpms/openssh-4.2p1-1tr.i586.rpm
828dd5e0018248a51c9678877f465d0c  2.2/rpms/openssh-clients-4.2p1-1tr.i586.rpm
ae0c4ad993e9635006dec7fb0a19b2ed  2.2/rpms/openssh-server-4.2p1-1tr.i586.rpm
e4d7b7d24bcfedaa4e018cd0b2b6b7c4  2.2/rpms/openssh-server-config-4.2p1-1tr.i586.rpm
79333b68b2dd477cc2b4009fe8de784b  2.2/rpms/squid-2.5.STABLE10-3tr.i586.rpm
- --------------------------------------------------------------------------


Trustix Security Team


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)

iD8DBQFDIWQoi8CEzsK9IksRAmoJAKCzb57JC/yUISs8/+QZHq1lXuJUGQCgjFse
W0v/I01lFWCAtoVIpYz1J/w=
=i+se
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • TSLSA-2005-0047 - multi Trustix Security Advisor (Sep 09)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault