Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200604-05 ] Doomsday: Format string vulnerability
From: Stefan Cornelius <dercorny () gentoo org>
Date: Thu, 6 Apr 2006 04:34:35 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200604-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Doomsday: Format string vulnerability
      Date: April 06, 2006
      Bugs: #128690
        ID: 200604-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Format string vulnerabilities in Doomsday may lead to the execution of
arbitrary code.

Background
==========

Doomsday is a modern gaming engine for popular ID games like Doom,
Heretic and Hexen.

Affected packages
=================

    -------------------------------------------------------------------
     Package             /   Vulnerable   /                 Unaffected
    -------------------------------------------------------------------
  1  games-fps/doomsday      <= 1.8.6-r1                   Vulnerable!
    -------------------------------------------------------------------
     NOTE: Certain packages are still vulnerable. Users should migrate
           to another package if one is available or wait for the
           existing packages to be marked stable by their
           architecture maintainers.

Description
===========

Luigi Auriemma discovered that Doomsday incorrectly implements
formatted printing.

Impact
======

A remote attacker could exploit these vulnerabilities to execute
arbitrary code with the rights of the user running the Doomsday server
or client by sending specially crafted strings.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

Doomsday has been masked in Portage pending the resolution of these
issues. All Doomsday users are advised to uninstall the package until
further notice.

    # emerge --ask --verbose --unmerge games-fps/doomsday

References
==========

  [ 1 ] CVE-2006-1618
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1618
  [ 2 ] Original advisory by Luigi Auriemma
        http://aluigi.altervista.org/adv/doomsdayfs-adv.txt

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200604-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200604-05 ] Doomsday: Format string vulnerability Stefan Cornelius (Apr 10)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]