Home page logo
/

bugtraq logo Bugtraq mailing list archives

Re: Invision Community Blog Mod 1.2.4 .PHP SQL Injection Vulnerability
From: emin () hasanov com
Date: 1 Dec 2006 06:10:49 -0000

Thanks for sharing!

Quick fix is to edit file forum/modules/blog/lib/entry_reply_entry.php

and change the following code (line 52 for me)
'where' =>      "entry_id = {$this->ipsclass->input['eid']}"                                                    
to
                                                   'where'      =>      "entry_id = 
'".intval($this->ipsclass->input['eid'])."'"


  By Date           By Thread  

Current thread:
  • Re: Invision Community Blog Mod 1.2.4 .PHP SQL Injection Vulnerability emin (Dec 01)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]