Home page logo
/

bugtraq logo Bugtraq mailing list archives

Low security hole affecting IPCalc's CGI wrapper
From: Tim Brown <timb () nth-dimension org uk>
Date: Sat, 22 Jul 2006 12:40:03 +0100

Hi,

I believe I've found a low level security hole relating to the way IPCalc's 
CGI wrapper sanitises input, which allows Javascript injection.

Hole is considered low since IPCalc's CGI wrapper has no privileged 
functionality, however of course it might be possible to use it as a vector 
to attack other applications hosted on the same web server.

I contacted the author (Krischan Jodies - <http://www.jodies.de/>) on the 7th, 
offering them 14 days to respond but have had no reply to acknowledge that 
the problem even exists, I've decided to publish this warning.

Tim
-- 
Tim Brown, Nth Dimension
<mailto:timb () nth-dimension org uk>
<http://www.nth-dimension.org.uk/>

Attachment: NDSA20060705.txt.asc
Description:


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault