Home page logo
/

bugtraq logo Bugtraq mailing list archives

UPDATE: [ GLSA 200605-08 ] PHP: Multiple vulnerabilities
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Sun, 30 Jul 2006 21:39:28 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory [UPDATE]               GLSA 200605-08:02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: PHP: Multiple vulnerabilities
      Date: May 08, 2006
   Updated: July 24, 2006
      Bugs: #127939, #128883, #131135, #133524
        ID: 200605-08:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Update
======

The initial fix did not properly fix the CVE-2006-1990 issue on 64 bit
systems.

The updated sections appear below.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  dev-lang/php       < 5.1.4                               >= 5.1.4
                                                          *>= 4.4.2-r2
  2  dev-lang/php     < 5.1.4-r4                           >= 5.1.4-r4
                                                          *>= 4.4.2-r6
    -------------------------------------------------------------------
     # Package 1 only applies to ARM, HPPA, PPC, S390, SH, SPARC, x86
       and x86-FBSD users.
     # Package 2 only applies to ALPHA, AMD64, IA64 and PPC64 users.
    -------------------------------------------------------------------
     2 affected packages; please see the notes above...
    -------------------------------------------------------------------

Resolution
==========

All PHP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose dev-lang/php

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200605-08.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • UPDATE: [ GLSA 200605-08 ] PHP: Multiple vulnerabilities Sune Kloppenborg Jeppesen (Jul 31)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]