Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200611-02 ] Qt: Integer overflow
From: Matthias Geerdsen <vorlon () gentoo org>
Date: Mon, 06 Nov 2006 14:52:14 +0100

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200611-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Qt: Integer overflow
      Date: November 06, 2006
      Bugs: #151838
        ID: 200611-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An integer overflow flaw in the Qt pixmap handling could possibly lead
to a Denial of Service or the remote execution of arbitrary code.

Background
==========

Qt is a cross-platform GUI toolkit, which is used e.g. by KDE.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  x11-libs/qt     < 4.1.4-r2                            >= 4.1.4-r2
                                                          *>= 3.3.6-r4

Description
===========

An integer overflow flaw has been found in the pixmap handling of Qt.

Impact
======

By enticing a user to open a specially crafted pixmap image in an
application using Qt, e.g. Konqueror, a remote attacker could be able
to cause an application crash or the execution of arbitrary code with
the rights of the user running the application.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Qt 3.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/qt-3.3.6-r4"

All Qt 4.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=x11-libs/qt-4.1.4-r2"

References
==========

  [ 1 ] CVE-2006-4811
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4811

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200611-02.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: signature.asc
Description: OpenPGP digital signature


  By Date           By Thread  

Current thread:
  • [ GLSA 200611-02 ] Qt: Integer overflow Matthias Geerdsen (Nov 06)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]