Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200610-11 ] OpenSSL: Multiple vulnerabilities
From: Raphael Marichez <falco () gentoo org>
Date: Tue, 24 Oct 2006 18:31:22 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200610-11
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: OpenSSL: Multiple vulnerabilities
      Date: October 24, 2006
      Bugs: #145510
        ID: 200610-11

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

OpenSSL contains multiple vulnerabilities including the possible remote
execution of arbitrary code.

Background
==========

OpenSSL is a toolkit implementing the Secure Sockets Layer, Transport
Layer Security protocols and a general-purpose cryptography library.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  dev-libs/openssl      < 0.9.8d                          >= 0.9.8d
                                                            *>= 0.9.7l

Description
===========

Tavis Ormandy and Will Drewry, both of the Google Security Team,
discovered that the SSL_get_shared_ciphers() function contains a buffer
overflow vulnerability, and that the SSLv2 client code contains a flaw
leading to a crash. Additionally Dr. Stephen N. Henson found that the
ASN.1 handler contains two Denial of Service vulnerabilities: while
parsing an invalid ASN.1 structure and while handling certain types of
public key.

Impact
======

An attacker could trigger the buffer overflow vulnerability by sending
a malicious suite of ciphers to an application using the vulnerable
function, and thus execute arbitrary code with the rights of the user
running the application. An attacker could also consume CPU and/or
memory by exploiting the Denial of Service vulnerabilities. Finally a
malicious server could crash a SSLv2 client through the SSLv2
vulnerability.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All OpenSSL 0.9.8 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.8d"

All OpenSSL 0.9.7 users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-libs/openssl-0.9.7l"

References
==========

  [ 1 ] CVE-2006-2937
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2937
  [ 2 ] CVE-2006-2940
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2940
  [ 3 ] CVE-2006-3738
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3738
  [ 4 ] CVE-2006-4343
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-4343

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200610-11.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200610-11 ] OpenSSL: Multiple vulnerabilities Raphael Marichez (Oct 24)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]