Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200710-26 ] HPLIP: Privilege escalation
From: Raphael Marichez <falco () gentoo org>
Date: Wed, 24 Oct 2007 23:59:20 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200710-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: HPLIP: Privilege escalation
      Date: October 24, 2007
      Bugs: #195565
        ID: 200710-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

The hpssd daemon might allow local attackers to execute arbitrary
commands with root privileges.

Background
==========

The Hewlett-Packard Linux Imaging and Printing system (HPLIP) provides
drivers for HP's inkjet and laser printers, scanners and fax machines.
It integrates with the Common UNIX Printing System (CUPS) and Scanner
Access Now Easy (SANE).

Affected packages
=================

    -------------------------------------------------------------------
     Package          /  Vulnerable  /                      Unaffected
    -------------------------------------------------------------------
  1  net-print/hplip     < 2.7.9-r1                      *>= 1.7.4a-r2
                                                           >= 2.7.9-r1

Description
===========

Kees Cook from the Ubuntu Security team discovered that the hpssd
daemon does not correctly validate user supplied data before passing it
to a "popen3()" call.

Impact
======

A local attacker may be able to exploit this vulnerability by sending a
specially crafted request to the hpssd daemon to execute arbitrary
commands with the privileges of the user running hpssd, usually root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All HPLIP users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose "net-print/hplip"

References
==========

  [ 1 ] CVE-2007-5208
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5208

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200710-26.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200710-26 ] HPLIP: Privilege escalation Raphael Marichez (Oct 25)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]