Home page logo
/

bugtraq logo Bugtraq mailing list archives

Omnistar Live Software Cross-Site Scripting Vulrnability
From: DoZ () HackersCenter com
Date: 29 Oct 2007 01:48:05 -0000

[HSC] Omnistar Live Software Cross-Site Scripting Vulrnability



Omnistar Live is web based PHP help desk software used by webmasters that combines 
live chat and helpdesk software in one easy to use solution. Our customer service software 
combines ticketed support (web and email based), live chat and a knowledgebase solution.
An attacker may leverage this issue to have arbitrary script code execute in the browser 
of an unsuspecting user in the context of the affected site. This may help the attacker 
steal cookie-based authentication credentials and launch
other attacks.


Hackers Center Security Group (http://www.hackerscenter.com)
Credit: Doz


Risk: Medium
Class: Input Validation Error


Vendor: http://www.omnistarlive.com
Product: Omnistar Live


* Attackers can exploit these issues via a web client.


Cross-Site Scripting:

/smartshop/users/kb.php?id=10002&category_id=XSS
/users/kb.php?category_id=XSS


Example of Advance Exploitation of the Application:

Once we have found that the application is vulrnable to Cross Site Scripting we see
that there is a form that will be our source of input to manipulate the Files.
Now we can advance this type of attack by injecting an evil script trough profile.php
page. Now we can inject any code into the Email Box and submit. Than you can view the 
result of code by going /users/tickets.php and "Submit New Ticket"




Only becoming a Ethical Hacker, you can stop a Hacker. Learn with out having
to pay thousands!- http://kit.hackerscenter.com - The most comprehensive security
pack you will ever find on the net!


  By Date           By Thread  

Current thread:
  • Omnistar Live Software Cross-Site Scripting Vulrnability DoZ (Oct 29)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault