Home page logo
/

bugtraq logo Bugtraq mailing list archives

[RISE-2007003] Firebird Relational Database Multiple Buffer Overflow Vulnerabilities
From: RISE Security <advisories () risesecurity org>
Date: Wed, 03 Oct 2007 23:59:34 -0300

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Firebird Relational Database Multiple Buffer Overflow Vulnerabilities

http://risesecurity.org/advisory/RISE-2007003/

Published: October 3, 2007
Updated: October 3, 2007

INTRODUCTION

There exists multiple vulnerabilities within functions of Firebird
Relational
Database, which when properly exploited can lead to remote compromise of the
vulnerable system.
These vulnerabilities were confirmed by us in the following versions of
Firebird
Relational Database, other versions may be also affected.

Firebird WI-V2.0.1.12855
Firebird WI-V2.0.0.12748
Firebird WI-V1.5.4.4910
Firebird WI-V1.5.3.4870
Firebird LI-V2.0.1.12855
Firebird LI-V2.0.0.12748
Firebird LI-V1.5.4.4910
Firebird LI-V1.5.3.4870

DETAILS

The vulnerable functions do not validate user supplied data when copying
it to a
stack-based buffer, resulting in a stack-based buffer overflow. The
exploitation
of these vulnerabilities are trivial and results in remote compromise of the
vulnerable system.

This is the list of vulnerable functions, some of them contain more than one
stack-based buffer overflow vulnerability.

1. INET_connect (Firebird 1.5)
2. SVC_attach (Firebird 1.5)
3. isc_attach_database (Firebird 2.0)
4. isc_create_database (Firebird 2.0)

These vulnerabilities can be triggered by sending specially crafted attach,
create and service attach requests.

Proof of concept codes for these vulnerabilities can be downloaded from our
website http://risesecurity.org/.

VENDOR

The vulnerabilities 1 and 2 were cerrected in Firebird XX-V2.0.0.12748,
3 and 4
were corrected in Firebird XX-V2.0.3.12981.

CREDITS

These vulnerabilities were discovered by Adriano Lima
<adriano () risesecurity org>
and Ramon de Carvalho Valle <ramon () risesecurity org>.

DISCLAIMER

The authors reserve the right not to be responsible for the topicality,
correctness, completeness or quality of the information provided in this
document. Liability claims regarding damage caused by the use of any
information
provided, including any kind of information which is incomplete or
incorrect,
will therefore be rejected.

APPENDIX

Proof of concept codes for these vulnerabilities can be downloaded from our
website http://risesecurity.org/.


$Id: RISE-2007003.txt 10 2007-10-04 00:58:59Z ramon $


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFHBFcWhFjK78TGSUERApYoAJ4yaoWo7aunx5WYz64IfGgxoWiKRwCfUnOW
A0bgGMII9z8uFrktgk0SSds=
=jnE+
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [RISE-2007003] Firebird Relational Database Multiple Buffer Overflow Vulnerabilities RISE Security (Oct 04)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]