Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 200804-30 ] KDE start_kdeinit: Multiple vulnerabilities
From: Matthias Geerdsen <vorlon () gentoo org>
Date: Tue, 29 Apr 2008 14:26:15 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200804-30
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: KDE start_kdeinit: Multiple vulnerabilities
      Date: April 29, 2008
      Bugs: #218933
        ID: 200804-30

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in start_kdeinit could possibly allow a local
attacker to execute arbitrary code with root privileges.

Background
==========

KDE is a feature-rich graphical desktop environment for Linux and
Unix-like operating systems. start_kdeinit is a wrapper for kdeinit.

Affected packages
=================

    -------------------------------------------------------------------
     Package           /  Vulnerable  /                     Unaffected
    -------------------------------------------------------------------
  1  kde-base/kdelibs        < 4.0                        *>= 3.5.8-r4
                                                          *>= 3.5.9-r3
                                                                 > 4.0
                                                               < 3.5.5

Description
===========

Vulnerabilities have been reported in the processing of user-controlled
data by start_kdeinit, which is setuid root by default.

Impact
======

A local attacker could possibly execute arbitrary code with root
privileges, cause a Denial of Service or send Unix signals to other
processes, when start_kdeinit is setuid root.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All kdelibs users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=kde-base/kdelibs-3.5.8-r4"

References
==========

  [ 1 ] CVE-2008-1671
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1671

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200804-30.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: signature.asc
Description: OpenPGP digital signature


  By Date           By Thread  

Current thread:
  • [ GLSA 200804-30 ] KDE start_kdeinit: Multiple vulnerabilities Matthias Geerdsen (Apr 29)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault