Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ MDVSA-2008:106 ] - Updated gnutls packages fix denial of service vulnerabilities
From: security () mandriva com
Date: Fri, 23 May 2008 19:19:00 -0600


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________
 
 Mandriva Linux Security Advisory                         MDVSA-2008:106
 http://www.mandriva.com/security/
 _______________________________________________________________________
 
 Package : gnutls
 Date    : May 23, 2008
 Affected: 2007.1, 2008.0, 2008.1, Corporate 4.0
 _______________________________________________________________________
 
 Problem Description:
 
 Flaws discovered in versions prior to 2.2.4 (stable) and 2.3.10
 (development) of GnuTLS allow an attacker to cause denial of service
 (application crash), and maybe (so far undetermined) execute arbitrary
 code.
 
 The updated packages have been patched to fix these flaws.
 
 Note that any applications using this library must be restarted for
 the update to take effect.
 _______________________________________________________________________

 References:
 
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1948
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1949
 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-1950
 _______________________________________________________________________
 
 Updated Packages:
 
 Mandriva Linux 2007.1:
 0823ae95b54db5e8260f6fc710dd34b2  2007.1/i586/gnutls-1.6.1-1.1mdv2007.1.i586.rpm
 03e54ad292b64efa9ec196ceb617b3a3  2007.1/i586/libgnutls13-1.6.1-1.1mdv2007.1.i586.rpm
 92103449ab3aab9d58f6b77d0a98bc6b  2007.1/i586/libgnutls13-devel-1.6.1-1.1mdv2007.1.i586.rpm 
 d60a104f11bdc47a1886b778d8cf8320  2007.1/SRPMS/gnutls-1.6.1-1.1mdv2007.1.src.rpm

 Mandriva Linux 2007.1/X86_64:
 977037a17dccdae58f32c7769ffe41d4  2007.1/x86_64/gnutls-1.6.1-1.1mdv2007.1.x86_64.rpm
 d4f0b755d5eaa2f4e009b06a8ee84b78  2007.1/x86_64/lib64gnutls13-1.6.1-1.1mdv2007.1.x86_64.rpm
 12ce8c8f834a8513fba416f17045e8a2  2007.1/x86_64/lib64gnutls13-devel-1.6.1-1.1mdv2007.1.x86_64.rpm 
 d60a104f11bdc47a1886b778d8cf8320  2007.1/SRPMS/gnutls-1.6.1-1.1mdv2007.1.src.rpm

 Mandriva Linux 2008.0:
 426dee92eb410b4ea95d72bb95b8191b  2008.0/i586/gnutls-2.0.0-2.1mdv2008.0.i586.rpm
 9c6d041a503bd22a486ae4ab9b9dea48  2008.0/i586/libgnutls13-2.0.0-2.1mdv2008.0.i586.rpm
 5e0fce3f50e56c1b6e3e3e511ec54913  2008.0/i586/libgnutls-devel-2.0.0-2.1mdv2008.0.i586.rpm 
 600e9dddd31f9dca30f24792d06a59d3  2008.0/SRPMS/gnutls-2.0.0-2.1mdv2008.0.src.rpm

 Mandriva Linux 2008.0/X86_64:
 386440004780f852335f569aed652030  2008.0/x86_64/gnutls-2.0.0-2.1mdv2008.0.x86_64.rpm
 c90ec5add91fce03f69dd2e7d0bc1c30  2008.0/x86_64/lib64gnutls13-2.0.0-2.1mdv2008.0.x86_64.rpm
 84a18017f22caf2b41347987d34dac77  2008.0/x86_64/lib64gnutls-devel-2.0.0-2.1mdv2008.0.x86_64.rpm 
 600e9dddd31f9dca30f24792d06a59d3  2008.0/SRPMS/gnutls-2.0.0-2.1mdv2008.0.src.rpm

 Mandriva Linux 2008.1:
 ae18e0cbaae63c33c758146345d88128  2008.1/i586/gnutls-2.3.0-2.1mdv2008.1.i586.rpm
 d12780e4b5dfd1adc38f777c1d05e8cb  2008.1/i586/libgnutls26-2.3.0-2.1mdv2008.1.i586.rpm
 2747ee390d9f415ed895384a9b3ff11a  2008.1/i586/libgnutls-devel-2.3.0-2.1mdv2008.1.i586.rpm 
 8f6fea3051fb772dbf2fed7db9e135d8  2008.1/SRPMS/gnutls-2.3.0-2.1mdv2008.1.src.rpm

 Mandriva Linux 2008.1/X86_64:
 80108975e78b52c8a0fb85243aa9e5ea  2008.1/x86_64/gnutls-2.3.0-2.1mdv2008.1.x86_64.rpm
 83f5d823404d4a9da542f6a20fe57ee7  2008.1/x86_64/lib64gnutls26-2.3.0-2.1mdv2008.1.x86_64.rpm
 042c7574023193bead114e6c53334c90  2008.1/x86_64/lib64gnutls-devel-2.3.0-2.1mdv2008.1.x86_64.rpm 
 8f6fea3051fb772dbf2fed7db9e135d8  2008.1/SRPMS/gnutls-2.3.0-2.1mdv2008.1.src.rpm

 Corporate 4.0:
 40385708c33d7e44db2e5752e3d74c8f  corporate/4.0/i586/gnutls-1.0.25-2.3.20060mlcs4.i586.rpm
 52a27ba26a2e6b1feb8854617c54ad7a  corporate/4.0/i586/libgnutls11-1.0.25-2.3.20060mlcs4.i586.rpm
 a72058f1264c7320740f56f2bd1c0217  corporate/4.0/i586/libgnutls11-devel-1.0.25-2.3.20060mlcs4.i586.rpm 
 2d32c61aa7bfdf360cdce77f398c682b  corporate/4.0/SRPMS/gnutls-1.0.25-2.3.20060mlcs4.src.rpm

 Corporate 4.0/X86_64:
 014f5b3d150b246e6802a50427a1ece1  corporate/4.0/x86_64/gnutls-1.0.25-2.3.20060mlcs4.x86_64.rpm
 3503f82acf876ddec1b084a0152820ca  corporate/4.0/x86_64/lib64gnutls11-1.0.25-2.3.20060mlcs4.x86_64.rpm
 29061f0e5e8ad8205ce9c04eb9d792e7  corporate/4.0/x86_64/lib64gnutls11-devel-1.0.25-2.3.20060mlcs4.x86_64.rpm 
 2d32c61aa7bfdf360cdce77f398c682b  corporate/4.0/SRPMS/gnutls-1.0.25-2.3.20060mlcs4.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFIN0HimqjQ0CJFipgRAiBsAKCR+nFMGh54xB307DhNZkfm6U1Q/QCgyHcR
7ulgM+iboZV+JfTfH+jWC8M=
=dIxA
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [ MDVSA-2008:106 ] - Updated gnutls packages fix denial of service vulnerabilities security (May 24)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault