Home page logo
/

bugtraq logo Bugtraq mailing list archives

[SECURITY] [DSA 2085-1] New lftp packages fix file overwrite vulnerability
From: Sebastien Delafond <seb () debian org>
Date: Tue, 3 Aug 2010 13:44:33 -0400

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ------------------------------------------------------------------------
Debian Security Advisory DSA-2085-1                security () debian org
http://www.debian.org/security/                     Sebastien Delafond
August 03, 2010                     http://www.debian.org/security/faq
- ------------------------------------------------------------------------

Package        : lftp
Vulnerability  : missing input validation
Problem type   : remote (local)
Debian-specific: no
CVE Id         : CVE-2010-2251

It was discovered that in lftp, a command-line HTTP/FTP client, there is
no proper validation of the filename provided by the server through the
Content-Disposition header; attackers can use this flaw by suggesting a
filename they wish to overwrite on the client machine, and then possibly
execute arbitrary code (for instance if the attacker elects to write a
dotfile in a home directory).

For the stable distribution (lenny), this problem has been fixed in
version 3.7.3-1+lenny1.

For the testing distribution (squeeze), this problem has been fixed in
version 4.0.6-1.

For the unstable distribution (sid), this problem has been fixed in
version 4.0.6-1.

We recommend that you upgrade your lftp packages.

Upgrade instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 5.0 alias lenny
- --------------------------------

Stable updates are available for alpha, amd64, arm, armel, hppa, i386, ia64, mips, mipsel, powerpc, s390 and sparc.

Source archives:

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1.dsc
    Size/MD5 checksum:     1059 64112d74da53a2b3fc9336618115e1eb
  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1.diff.gz
    Size/MD5 checksum:    13674 09040587c1e33a732682d425a3627da2
  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3.orig.tar.gz
    Size/MD5 checksum:  1844300 576a7b1249038ba761325671dd2eba26

alpha architecture (DEC Alpha)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_alpha.deb
    Size/MD5 checksum:   711424 91c615f46c5dc48adc6dd45d20076b9a

amd64 architecture (AMD x86_64 (AMD64))

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_amd64.deb
    Size/MD5 checksum:   656172 15b40a343fecd7984b95e32dcda6eeed

arm architecture (ARM)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_arm.deb
    Size/MD5 checksum:   574538 63404d61be53f9d459ee8171e027b9c2

armel architecture (ARM EABI)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_armel.deb
    Size/MD5 checksum:   581470 7d80d23b595a9a087c76b6bcdf83e285

hppa architecture (HP PA RISC)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_hppa.deb
    Size/MD5 checksum:   671790 1cebd061da662b9cf2479eeea5c8f9a1

i386 architecture (Intel ia32)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_i386.deb
    Size/MD5 checksum:   586716 e86f9d7ae3e182c90f85b1f92924ba1c

ia64 architecture (Intel ia64)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_ia64.deb
    Size/MD5 checksum:   877390 ae790318fc5101487f6871bc108ae091

mips architecture (MIPS (Big Endian))

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_mips.deb
    Size/MD5 checksum:   649034 334ee6e763e7de4c1efd7b55875e1d04

mipsel architecture (MIPS (Little Endian))

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_mipsel.deb
    Size/MD5 checksum:   647518 409d0d333d2370f7003ff54a4a11cab3

powerpc architecture (PowerPC)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_powerpc.deb
    Size/MD5 checksum:   613568 9bd37572fc37a038c5f17bb626a72634

s390 architecture (IBM S/390)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_s390.deb
    Size/MD5 checksum:   633538 e7b2bd269c910bd39c6cd924b62b4059

sparc architecture (Sun SPARC/UltraSPARC)

  http://security.debian.org/pool/updates/main/l/lftp/lftp_3.7.3-1+lenny1_sparc.deb
    Size/MD5 checksum:   585096 85f9f06f175d544e0ac380a29e2e00e3


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce () lists debian org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)

iEYEARECAAYFAkxYVUgACgkQXm3vHE4uylqXmgCglkUrDHZ2BuqxvNzlQ4SCntvt
5gQAn1ef2jwH5CrM3qcWTamhhd2nhXFy
=D681
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [SECURITY] [DSA 2085-1] New lftp packages fix file overwrite vulnerability Sebastien Delafond (Aug 03)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]