Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ MDVSA-2010:255 ] php-intl
From: security () mandriva com
Date: Wed, 15 Dec 2010 16:32:00 +0100

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2010:255
 http://www.mandriva.com/security/
 _______________________________________________________________________

 Package : php-intl
 Date    : December 15, 2010
 Affected: Enterprise Server 5.0
 _______________________________________________________________________

 Problem Description:

 A vulnerability was discovered and corrected in php-intl:
 
 Integer overflow in the NumberFormatter::getSymbol (aka
 numfmt_get_symbol) function in PHP 5.3.3 and earlier allows
 context-dependent attackers to cause a denial of service (application
 crash) via an invalid argument (CVE-2010-4409).
 
 The updated packages have been upgraded to php-intl-1.1.2 and patched
 to correct this issue.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-4409
 _______________________________________________________________________

 Updated Packages:

 Mandriva Enterprise Server 5:
 e4150c29c342b12bf02f802692c3e9af  mes5/i586/php-intl-1.1.2-0.1mdvmes5.1.i586.rpm 
 cf1acac56b390efc3b731307a8d5b139  mes5/SRPMS/php-intl-1.1.2-0.1mdvmes5.1.src.rpm

 Mandriva Enterprise Server 5/X86_64:
 0c5c740e3a0596ba5223de67e4219f58  mes5/x86_64/php-intl-1.1.2-0.1mdvmes5.1.x86_64.rpm 
 cf1acac56b390efc3b731307a8d5b139  mes5/SRPMS/php-intl-1.1.2-0.1mdvmes5.1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFNCLRJmqjQ0CJFipgRAlM9AKCZel2zsKCm/8uDytkhQLB6l9xRegCdH3i7
t6AZrhZgu20J+8l2wggMT6Y=
=aPyA
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [ MDVSA-2010:255 ] php-intl security (Dec 15)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]