Home page logo
/

bugtraq logo Bugtraq mailing list archives

XSS vulnerability in Habari
From: advisory () htbridge ch
Date: Tue, 21 Dec 2010 11:38:22 +0100 (CET)

Vulnerability ID: HTB22731
Reference: http://www.htbridge.ch/advisory/xss_vulnerability_in_habari.html
Product: Habari
Vendor: Habari ( http://habariproject.org/en/ ) 
Vulnerable Version: 0.6.5
Vendor Notification: 02 December 2010 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.

The vulnerability exists due to failure in the "/system/admin/dash_additem.php" script to properly sanitize 
user-supplied input in "additem_form" variable when register_globals is on. Successful exploitation of this 
vulnerability could result in a compromise of the application, theft of cookie-based authentication credentials, 
disclosure or modification of sensitive data.

Attacker can use browser to exploit this vulnerability. The following PoC is available:


http://[host]/system/admin/dash_additem.php?additem_form=<script>alert('XSS');</script>


Solution: Upgrade to the most recent version


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault