Home page logo
/

bugtraq logo Bugtraq mailing list archives

XSS in HTML-EDIT CMS
From: advisory () htbridge ch
Date: Tue, 21 Dec 2010 11:38:50 +0100 (CET)

Vulnerability ID: HTB22735
Reference: http://www.htbridge.ch/advisory/xss_in_html_edit_cms.html
Product: HTML-EDIT CMS
Vendor: html-edit web services ( http://www.html-edit.org/ ) 
Vulnerable Version: 3.1.8
Vendor Notification: 02 December 2010 
Vulnerability Type: XSS (Cross Site Scripting)
Status: Fixed by Vendor
Risk level: Medium 
Credit: High-Tech Bridge SA - Ethical Hacking & Penetration Testing (http://www.htbridge.ch/) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.
The vulnerability exists due to failure in the "/index.php" script to properly sanitize user-supplied input in "error" 
variable. Successful exploitation of this vulnerability could result in a compromise of the application, theft of 
cookie-based authentication credentials, disclosure or modification of sensitive data.

Attacker can use browser to exploit this vulnerability. The following PoC is available:


http://[host]/index.php?error=<script>alert(document.cookie)</script>

Solution: Upgrade to the most recent version


  By Date           By Thread  

Current thread:
  • XSS in HTML-EDIT CMS advisory (Dec 21)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]