Home page logo
/

bugtraq logo Bugtraq mailing list archives

Vulnerabilities in PHPShop
From: "MustLive" <mustlive () websecurity com ua>
Date: Sat, 6 Nov 2010 19:32:40 +0200

Hello Bugtraq!

I want to warn you about Insufficient Anti-automation, Cross-Site Scripting,
Denial of Service and Full path disclosure vulnerabilities in PHPShop. This
is engine for online shops.

-------------------------
Affected products:
-------------------------

Vulnerable are PHPShop 2.1 EE and previous versions (and potentially next
versions).

----------
Details:
----------

Insufficient Anti-automation (WASC-21):

http://site/users/register.html

At this page the vulnerable captcha is using.

http://websecurity.com.ua/uploads/2010/PHPShop%20CAPTCHA%20bypass.html

http://site/users/sendpassword.html

At this page there is no protection against automated requests (captcha).

XSS (with captcha bypass) (WASC-08):

http://websecurity.com.ua/uploads/2010/PHPShop%20XSS.html

DoS (WASC-10):

http://site/search/?words=.&p=all&cat=0

Full path disclosure (WASC-13):

http://site/page/’

------------
Timeline:
------------

2010.09.08 - announced at my site.
2010.09.11 - informed developers.
2010.11.06 - disclosed at my site.

I mentioned about these vulnerabilities at my site
(http://websecurity.com.ua/4512/).

Best wishes & regards,
MustLive
Administrator of Websecurity web site
http://websecurity.com.ua


  By Date           By Thread  

Current thread:
  • Vulnerabilities in PHPShop MustLive (Nov 08)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]