Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ MDVSA-2011:086 ] polkit
From: security () mandriva com
Date: Mon, 16 May 2011 09:40:00 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2011:086
 http://www.mandriva.com/security/
 _______________________________________________________________________

 Package : polkit
 Date    : May 16, 2011
 Affected: 2010.1
 _______________________________________________________________________

 Problem Description:

 A vulnerability has been found and corrected in polkit:
 
 A race condition flaw was found in the PolicyKit pkexec utility
 and polkitd daemon. A local user could use this flaw to appear as a
 privileged user to pkexec, allowing them to execute arbitrary commands
 as root by running those commands with pkexec (CVE-2011-1485).
 
 The updated packages have been patched to correct this issue.
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-1485
 _______________________________________________________________________

 Updated Packages:

 Mandriva Linux 2010.1:
 6052bdd9c2612edbe64a16ba5e5099cb  2010.1/i586/libpolkit1_0-0.96-2.1mdv2010.2.i586.rpm
 7a034bdcf757bc1e5883d798a4f28d1c  2010.1/i586/libpolkit1-devel-0.96-2.1mdv2010.2.i586.rpm
 6fb9bd449e65d293bc69c03740db8d5f  2010.1/i586/polkit-0.96-2.1mdv2010.2.i586.rpm 
 be925eb746fce0c406c623e345929d29  2010.1/SRPMS/polkit-0.96-2.1mdv2010.2.src.rpm

 Mandriva Linux 2010.1/X86_64:
 3ba97482125ab02a75eb6fc860f9f224  2010.1/x86_64/lib64polkit1_0-0.96-2.1mdv2010.2.x86_64.rpm
 ceb8d48886baf234922d00a024db96ce  2010.1/x86_64/lib64polkit1-devel-0.96-2.1mdv2010.2.x86_64.rpm
 9b0c45b8933dd25379f784876ffbb1d5  2010.1/x86_64/polkit-0.96-2.1mdv2010.2.x86_64.rpm 
 be925eb746fce0c406c623e345929d29  2010.1/SRPMS/polkit-0.96-2.1mdv2010.2.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/security/advisories

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iD8DBQFN0KkXmqjQ0CJFipgRApwKAJ9RzRdnAPmPjnpOx9fd9MTbMPDGwACdHbit
ltRLZTGNWwRO1P/LFVnwwnk=
=qd50
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [ MDVSA-2011:086 ] polkit security (May 16)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault