Home page logo
/

bugtraq logo Bugtraq mailing list archives

HTB22966: XSS in (e)2 interactive Photo Gallery
From: advisory () htbridge ch
Date: Tue, 3 May 2011 15:27:14 +0200 (CEST)

Vulnerability ID: HTB22966
Reference: http://www.htbridge.ch/advisory/xss_in_e2_interactive_photo_gallery.html
Product: (e)2 interactive Photo Gallery
Vendor: http://www.e2interactive.com ( http://www.e2interactive.com ) 
Vulnerable Version: 0.9
Vendor Notification: 19 April 2011 
Vulnerability Type: XSS (Cross Site Scripting)
Risk level: Medium 
Credit: High-Tech Bridge SA Security Research Lab ( http://www.htbridge.ch/advisory/ ) 

Vulnerability Details:
User can execute arbitrary JavaScript code within the vulnerable application.
The vulnerability exists due to failure in the "/uploader/index.php" script to properly sanitize user-supplied input.
Successful exploitation of this vulnerability could result in a compromise of the application, theft of cookie-based 
authentication credentials, disclosure or modification of sensitive data.
The following PoC is available:


http://[host]/uploader/index.php/%22%3E%3Cscript%3Ealert%28123%29;%3C/script%3E




  By Date           By Thread  

Current thread:
  • HTB22966: XSS in (e)2 interactive Photo Gallery advisory (May 03)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]