Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ GLSA 201110-05 ] GnuTLS: Multiple vulnerabilities
From: Tobias Heinlein <keytoaster () gentoo org>
Date: Mon, 10 Oct 2011 23:59:06 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201110-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: GnuTLS: Multiple vulnerabilities
     Date: October 10, 2011
     Bugs: #281224, #292025
       ID: 201110-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities were found in GnuTLS, allowing for easier
man-in-the-middle attacks.

Background
==========

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0
protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-libs/gnutls              < 2.10.0                  >= 2.10.0

Description
===========

Multiple vulnerabilities have been discovered in GnuTLS. Please review
the CVE identifiers referenced below for details.

Impact
======

An attacker could perform man-in-the-middle attacks to spoof arbitrary
SSL servers via a crafted certificate issued by a legitimate
Certification Authority or to inject an arbitrary amount of chosen
plaintext into the beginning of the application protocol stream,
allowing for further exploitation.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All GnuTLS users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.10.0"

NOTE: This is a legacy GLSA. Updates for all affected architectures are
available since August 6, 2010. It is likely that your system is
already no longer affected by this issue.

References
==========

[ 1 ] CVE-2009-2730
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-2730
[ 2 ] CVE-2009-3555
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3555

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 http://security.gentoo.org/glsa/glsa-201110-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2011 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: signature.asc
Description: OpenPGP digital signature


  By Date           By Thread  

Current thread:
  • [ GLSA 201110-05 ] GnuTLS: Multiple vulnerabilities Tobias Heinlein (Oct 11)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault