Home page logo
/

bugtraq logo Bugtraq mailing list archives

[SECURITY] [DSA 2457-1] iceweasel security update
From: Moritz Muehlenhoff <jmm () debian org>
Date: Tue, 24 Apr 2012 22:35:21 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- -------------------------------------------------------------------------
Debian Security Advisory DSA-2457-1                   security () debian org
http://www.debian.org/security/                        Moritz Muehlenhoff
April 24, 2012                         http://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : iceweasel
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2012-0467 CVE-2012-0470 CVE-2012-0471 CVE-2012-0477 
                 CVE-2012-0479

Several vulnerabilities have been discovered in Iceweasel, a web
browser based on Firefox. The included XULRunner library provides
rendering services for several other applications included in Debian.

CVE-2012-0467
 
   Bob Clary, Christian Holler, Brian Hackett, Bobby Holley, Gary
   Kwong, Hilary Hall, Honza Bambas, Jesse Ruderman, Julian Seward,
   and Olli Pettay discovered memory corruption bugs, which may lead
   to the execution of arbitrary code.

CVE-2012-0470

   Atte Kettunen discovered that a memory corruption bug in
   gfxImageSurface may lead to the execution of arbitrary code.

CVE-2012-0471

   Anne van Kesteren discovered that incorrect multibyte octet
   decoding may lead to cross-site scripting.

CVE-2012-0477

   Masato Kinugawa discovered that incorrect encoding of
   Korean and Chinese character sets may lead to cross-site scripting.

CVE-2012-0479

   Jeroen van der Gun discovered a spoofing vulnerability in the
   presentation of Atom and RSS feeds over HTTPS.

For the stable distribution (squeeze), this problem has been fixed in
version 3.5.16-14.

For the unstable distribution (sid), this problem has been fixed in
version 10.0.4esr-1.

For the experimental distribution, this problem will be fixed soon.


We recommend that you upgrade your iceweasel packages.

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: http://www.debian.org/security/

Mailing list: debian-security-announce () lists debian org
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAk+XDkoACgkQXm3vHE4uylqfngCaAt6fHj+dr/zvoi0c4J3skHfR
ftcAoLCxfj+mh6m0Uv0lJ734BoVYAYmd
=m0na
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [SECURITY] [DSA 2457-1] iceweasel security update Moritz Muehlenhoff (Apr 25)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]