Home page logo
/

bugtraq logo Bugtraq mailing list archives

Updated - CA20121018-01: Security Notice for CA ARCserve Backup
From: "Kotas, Kevin J" <Kevin.Kotas () ca com>
Date: Mon, 14 Jan 2013 19:37:24 +0000

-----BEGIN PGP SIGNED MESSAGE-----

CA20121018-01: Security Notice for CA ARCserve Backup

Issued: October 18, 2012
Updated: January 2, 2012

CA Technologies support is alerting customers to multiple risks with
certain CA ARCserve Backup RPC services. Two vulnerabilities exist
that can allow a remote attacker to execute arbitrary code or cause
a denial of service condition.

The first vulnerability, CVE-2012-2971, occurs due to a flaw with how
RPC requests are processed. An attacker can potentially execute
arbitrary code or cause a denial of service on server installations.

The second vulnerability, CVE-2012-2972, occurs due to insufficient
validation of certain RPC requests and exploitation can result in a
service crash. This vulnerability affects both server and agent
installations.

Risk Rating

High

Platform

Windows

Affected Products

CA ARCserve Backup for Windows r12.5
CA ARCserve Backup for Windows r15
CA ARCserve Backup for Windows r16

How to determine if the installation is affected

CA ARCserve Backup for Windows r12.5, r15, r16:

1. Run the ARCserve Patch Management utility. From the Windows Start
menu, the program can be found under Programs->CA->ARCserve Patch
Management->Patch Status.
2. The main patch status screen will indicate if the patch in the
below table is applied. If the patch is not applied, then the
installation is vulnerable.

Product
Patch

CA ARCserve Backup for Windows r12.5
RO49917

CA ARCserve Backup for Windows r15
RO52480

CA ARCserve Backup for Windows r16
RO52479

Solution

CA ARCserve Backup for Windows r12.5:
RO49917

CA ARCserve Backup for Windows r15:
RO52480

CA ARCserve Backup for Windows r16:
RO52479

References

CVE-2012-2971 - RPC remote code execution
CVE-2012-2972 - RPC denial of service

CA20121018-01: Security Notice for CA ARCserve Backup
http://goo.gl/Y9HKr

Acknowledgement

CVE-2012-2971, CVE-2012-2971 - Matteo Memelli of Offensive Security

Change History

Version 1.0: Initial Release
Version 1.1: January 02, 2013 - Updated r15 and 16 patches due to the
original patches not fully addressing the vulnerabilities with the NAS
option. ARCserve Backup r15 patch RO49916 is replaced with RO52480 and
the r16 patch RO49750 is replaced with RO52479. Customers using the
NAS option must install the replacement patches to be fully protected
against this vulnerability.

If additional information is required, please contact CA Technologies
Support at http://support.ca.com/

If you discover a vulnerability in CA Technologies products,
please report your findings to the CA Technologies Product
Vulnerability Response Team:
http://goo.gl/nSMh9

CA Technologies Security Notices
https://support.ca.com/irj/portal/anonymous/phpsbpldgpg

Regards,

Kevin Kotas
Director, CA Technologies Product Vulnerability Response Team

Copyright (c) 2012 CA. All Rights Reserved. One CA Plaza, Islandia,
N.Y. 11749. All other trademarks, trade names, service marks, and
logos referenced herein belong to their respective companies.

-----BEGIN PGP SIGNATURE-----
Version: PGP Desktop 10.2.1 (Build 4940)
Charset: utf-8

wsBVAwUBUPRUXZI1FvIeMomJAQHJBAf+KZHXLp3uvyXxNVkkVCdcSQc+8aDQX0ey
QmPK0dFQ7TLKrQ+8bFjd9JGULSDfdTsEQprbjfpt0N+SqTuOuiVdSiuw/ParXJY0
OX8sat+tIb9a60QW18ybgm7+B/zMthypdCfdYjUBWDyr3AJRxdHaMVgEqNZ3JTUk
o4dikbquxVcuqupMAGBUVR9+pLZ/tqoJ9XHoiJ48Z0JqQp1clar1/+METfjiFAz3
KeLziFFKyEoIHRO/IYBp7j6VL+KmchBeinoIpb7wOJ86LTqXKVomDz9dpgRU2zK5
WOH9PpJc3h/hGkuE86tjnQWeo8eANge/RT/5/o9/24NDVWvCjktz+Q==
=667b
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • Updated - CA20121018-01: Security Notice for CA ARCserve Backup Kotas, Kevin J (Jan 14)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]