Home page logo
/

bugtraq logo Bugtraq mailing list archives

[ MDVSA-2013:178 ] nfs-utils
From: security () mandriva com
Date: Tue, 25 Jun 2013 14:18:00 +0200

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 _______________________________________________________________________

 Mandriva Linux Security Advisory                         MDVSA-2013:178
 http://www.mandriva.com/en/support/security/
 _______________________________________________________________________

 Package : nfs-utils
 Date    : June 25, 2013
 Affected: Business Server 1.0
 _______________________________________________________________________

 Problem Description:

 Updated nfs-utils packages fix security vulnerability
 
 It was reported that rpc.gssd in nfs-utils is vulnerable to
 DNS spoofing due to it depending on PTR resolution for GSSAPI
 authentication. Because of this, if a user where able to poison DNS to
 a victim's computer, they would be able to trick rpc.gssd into talking
 to another server (perhaps with less security) than the intended server
 (with stricter security). If the victim has write access to the second
 (less secure) server, and the attacker has read access (when they
 normally might not on the secure server), the victim could write files
 to that server, which the attacker could obtain (when normally they
 would not be able to). To the victim this is transparent because the
 victim's computer asks the KDC for a ticket to the second server due to
 reverse DNS resolution; in this case Krb5 authentication does not fail
 because the victim is talking to the correct server (CVE-2013-1923).
 _______________________________________________________________________

 References:

 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-1923
 http://advisories.mageia.org/MGASA-2013-0178.html
 _______________________________________________________________________

 Updated Packages:

 Mandriva Business Server 1/X86_64:
 ef6b2113ca2c817fc22efcc1ac86cb4b  mbs1/x86_64/nfs-utils-1.2.5-2.1.mbs1.x86_64.rpm
 b757876d603028118ed714a379632c87  mbs1/x86_64/nfs-utils-clients-1.2.5-2.1.mbs1.x86_64.rpm 
 1b545015a01bd04c6db45b4f37e49652  mbs1/SRPMS/nfs-utils-1.2.5-2.1.mbs1.src.rpm
 _______________________________________________________________________

 To upgrade automatically use MandrivaUpdate or urpmi.  The verification
 of md5 checksums and GPG signatures is performed automatically for you.

 All packages are signed by Mandriva for security.  You can obtain the
 GPG public key of the Mandriva Security Team by executing:

  gpg --recv-keys --keyserver pgp.mit.edu 0x22458A98

 You can view other update advisories for Mandriva Linux at:

  http://www.mandriva.com/en/support/security/advisories/

 If you want to report vulnerabilities, please contact

  security_(at)_mandriva.com
 _______________________________________________________________________

 Type Bits/KeyID     Date       User ID
 pub  1024D/22458A98 2000-07-10 Mandriva Security Team
  <security*mandriva.com>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iD8DBQFRyWBBmqjQ0CJFipgRAvHXAJoCmWHHuwaboTIg5th6kc9gilZfCwCfZG/L
9BuHlQy28NrvSrp1vgkUmWg=
=8JEC
-----END PGP SIGNATURE-----


  By Date           By Thread  

Current thread:
  • [ MDVSA-2013:178 ] nfs-utils security (Jun 25)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]