Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[SECURITY] [DSA 604-1] New hpsockd packages fix denial of service
From: debian-security-announce () lists debian org
Date: Fri, 3 Dec 2004 09:18:54 +0100 (CET)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 604-1                     security () debian org
http://www.debian.org/security/                             Martin Schulze
December 3rd, 2004                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : hpsockd
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-0993

"infamous41md" discovered a buffer overflow condition in hpsockd, the
socks server written at Hewlett-Packard.  An exploit could cause the
program to crash or may have worse effect.

For the stable distribution (woody) this problem has been fixed in
version 0.6.woody1.

For the unstable distribution (sid) this problem has been fixed in
version 0.14.

We recommend that you upgrade your hpsockd package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1.dsc
      Size/MD5 checksum:      526 d5ac263f8a527e97c8d707977351805a
    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1.tar.gz
      Size/MD5 checksum:   127019 2de411d806f925658b771ffb1c974c41

  Alpha architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_alpha.deb
      Size/MD5 checksum:   115444 65338a0efb88db831b690a4c76d70997

  ARM architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_arm.deb
      Size/MD5 checksum:   104214 fdd81a813a8023b9585603cf53610616

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_i386.deb
      Size/MD5 checksum:    98588 805aef90031fa41a3cca9fa28b26d508

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_ia64.deb
      Size/MD5 checksum:   140132 0f8a29392e10ae44652f76534a420b0a

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_hppa.deb
      Size/MD5 checksum:   111672 b643ff9b7e5964592b3c194b8fe7203b

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_m68k.deb
      Size/MD5 checksum:    94430 911addc14236228693687c303788ad3a

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_mips.deb
      Size/MD5 checksum:   110742 63e55da32013613da6e69b7f9a84b97d

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_mipsel.deb
      Size/MD5 checksum:   111172 7c82b76671b118ca734f48c5e22e3245

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_powerpc.deb
      Size/MD5 checksum:   101516 7447d074ff41cc3ad6873d2f423cc4fd

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_s390.deb
      Size/MD5 checksum:   101594 add45d166bf0c926e143fd70c5a09ab1

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/h/hpsockd/hpsockd_0.6.woody1_sparc.deb
      Size/MD5 checksum:   114216 510aca051ce938553e20af4f53104f46


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce () lists debian org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBsCFuW5ql+IAeqTIRAneqAJ9u031JQ7QCQVkLGW0VmGbSIjTmuACgoNdl
JZvvyfXhWJsLWoKJVoJO8a4=
=mql1
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html


  By Date           By Thread  

Current thread:
  • [SECURITY] [DSA 604-1] New hpsockd packages fix denial of service debian-security-announce (Dec 03)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault