Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

Re: Official IFRAME patch - make sure it installs correctly
From: Kevin <kkadow () gmail com>
Date: Wed, 1 Dec 2004 23:27:10 -0600

On Thu, 2 Dec 2004 01:49:52 +0100, Berend-Jan Wever
<skylined () edup tudelft nl> wrote:
The IFRAME vulnerability has been patched, see http://www.microsoft.com/technet/security/bulletin/ms04-040.mspx

The wording in ms04-040 is so vague, I am not entirely sure that this
patch is a fix for the IFRAME bug(s)?

*** Make sure you are patched after installing ***
I installed it using "Automatic Updates" (on Win2ksp4), rebooted and loaded my InternetExploiter.html: IT STILL 
WORKED!!
Even though both "Automatic Updates" and "http://windowsupdate.microsoft.com"; reported that I was patched!?!
I manually downloaded the exe and ran it, rebooted and now I'm finally truely patched.

Just so I am clear, after automatic updates applied the "critical
patch" on W2KSP4 and rebooted, the IFRAME exploit still worked, but
manually downloading the executable given in the Microsoft alert and
running it results in a system on which the IFRAME exploit no longer
works?

This would be confirmation that ms04-040 actually does address the
IFRAME exploit.


Kevin

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html


  By Date           By Thread  

Current thread:
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]