Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[SECURITY] [DSA 595-1] New bnc packages arbitrary code execution
From: debian-security-announce () lists debian org
Date: Wed, 24 Nov 2004 08:52:45 +0100 (CET)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 595-1                     security () debian org
http://www.debian.org/security/                             Martin Schulze
November 24th, 2004                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : bnc
Vulnerability  : buffer overflow
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2004-1052

Leon Juranic discovered that BNC, an IRC session bouncing proxy, does
not always protect buffers from being overwritten.  This could
exploited by a malicious IRC server to overflow a buffer of limited
size and execute arbitrary code on the client host.

For the stable distribution (woody) this problem has been fixed in
version 2.6.4-3.3.

This package does not exist in the testing or unstable distributions.

We recommend that you upgrade your bnc package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3.dsc
      Size/MD5 checksum:      543 a1450f3cf6b80026ec903f15f6585ae8
    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3.diff.gz
      Size/MD5 checksum:     3062 64db73a4d5fb93cd8d039ba13eb4b3dc
    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4.orig.tar.gz
      Size/MD5 checksum:    44333 1767b5bfdfd1c7a4a51a4114a326d014

  Alpha architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_alpha.deb
      Size/MD5 checksum:    30828 e8dd80226ae437e1f3d9bbcb694467a7

  ARM architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_arm.deb
      Size/MD5 checksum:    26770 c0ee6446147dc99465cebd1bda6dda60

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_i386.deb
      Size/MD5 checksum:    26266 c98bb8052220d7c869fd691059cc4b33

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_ia64.deb
      Size/MD5 checksum:    36164 d7ae31f108e9b82678c06695f241e046

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_hppa.deb
      Size/MD5 checksum:    29878 53cb733232eff24419c98ce67d45d056

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_m68k.deb
      Size/MD5 checksum:    25844 d6298a6dd44eae95a2a84d38f0bc09d1

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_mips.deb
      Size/MD5 checksum:    29236 bd291995072ad9e3172c4f2683412e7c

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_mipsel.deb
      Size/MD5 checksum:    29262 fd73461c1b0e65fa78424fc3f9b9631b

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_powerpc.deb
      Size/MD5 checksum:    27718 4058b8b6d4bb98614941f6587e6f8f94

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_s390.deb
      Size/MD5 checksum:    27232 99d2ddd170aa5b8425b9c2a0c5d74b2a

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/b/bnc/bnc_2.6.4-3.3_sparc.deb
      Size/MD5 checksum:    29906 4276473db008684a75644ce7512d9a59


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce () lists debian org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFBpD3NW5ql+IAeqTIRAqRhAKC6QOgZOwqRrPB3ZM2b3QYWqMB5vgCgusrM
s4nTY7nV6ZNkYl8CojVmAeQ=
=NeYx
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.netsys.com/full-disclosure-charter.html


  By Date           By Thread  

Current thread:
  • [SECURITY] [DSA 595-1] New bnc packages arbitrary code execution debian-security-announce (Nov 24)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]
AlienVault