Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[ GLSA 200410-29 ] PuTTY: Pre-authentication buffer overflow
From: Sune Kloppenborg Jeppesen <jaervosz () gentoo org>
Date: Wed, 27 Oct 2004 23:47:43 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200410-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PuTTY: Pre-authentication buffer overflow
      Date: October 27, 2004
      Bugs: #69123
        ID: 200410-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PuTTY contains a vulnerability allowing an SSH server to execute
arbitrary code on the connecting client.

Background
==========

PuTTY is a free implementation of Telnet and SSH for Win32 and Unix
platforms, along with an xterm terminal emulator.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /  Vulnerable  /                       Unaffected
    -------------------------------------------------------------------
  1  net-misc/putty       <= 0.55                              >= 0.56

Description
===========

PuTTY fails to do proper bounds checking on SSH2_MSG_DEBUG packets. The
"stringlen" parameter value is incorrectly checked due to signedness
issues. Note that this vulnerability is similar to the one described in
GLSA 200408-04 but not the same.

Impact
======

When PuTTY connects to a server using the SSH2 protocol, an attacker
may be able to send specially crafted packets to the client, resulting
in the execution of arbitrary code with the permissions of the user
running PuTTY. Note that this is possible during the authentication
process but before host key verification.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PuTTY users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/putty-0.56"

References
==========

  [ 1 ] iDEFENSE Security Advisory 10.27.04
        http://www.idefense.com/application/poi/display?id=155
  [ 2 ] PuTTY ChangeLog
        http://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200410-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/1.0

Attachment: _bin
Description:


  By Date           By Thread  

Current thread:
  • [ GLSA 200410-29 ] PuTTY: Pre-authentication buffer overflow Sune Kloppenborg Jeppesen (Oct 27)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]