Home page logo
/

fulldisclosure logo Full Disclosure mailing list archives

[ GLSA 200608-27 ] Motor: Execution of arbitrary code
From: Raphael Marichez <falco () gentoo org>
Date: Tue, 29 Aug 2006 17:03:14 +0200

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200608-27
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Motor: Execution of arbitrary code
      Date: August 29, 2006
      Bugs: #135020
        ID: 200608-27

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Motor uses a vulnerable ktools library, which could lead to the
execution of arbitrary code.

Background
==========

Motor is a text mode based programming environment for Linux, with a
syntax highlighting feature, project manager, makefile generator, gcc
and gdb front-end, and CVS integration.

Affected packages
=================

    -------------------------------------------------------------------
     Package         /  Vulnerable  /                       Unaffected
    -------------------------------------------------------------------
  1  dev-util/motor     < 3.4.0-r1                        *>= 3.3.0-r1
                                                           >= 3.4.0-r1

Description
===========

In November 2005, Zone-H Research reported a boundary error in the
ktools library in the VGETSTRING() macro of kkstrtext.h, which may
cause a buffer overflow via an overly long input string.

Impact
======

A remote attacker could entice a user to use a malicious file or input,
which could lead to the crash of Motor and possibly the execution of
arbitrary code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Motor 3.3.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-util/motor-3.3.0-r1"

All motor 3.4.x users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-util/motor-3.4.0-r1"

References
==========

  [ 1 ] CVE-2005-3863
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-3863

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200608-27.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security () gentoo org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

Attachment: _bin
Description:

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/

  By Date           By Thread  

Current thread:
  • [ GLSA 200608-27 ] Motor: Execution of arbitrary code Raphael Marichez (Aug 29)
[ Nmap | Sec Tools | Mailing Lists | Site News | About/Contact | Advertising | Privacy ]